have messed up my hard drive please help!

djneils98

macrumors newbie
Original poster
Jul 13, 2015
27
6
so i wanted to convert my osx mojave install to apfs as I couldn't install the new version of osx with the old file system
I did the conversion in the disk utility app in recovery mode.it seemed to work but the computer wouldn't boot after :(

so I tried to install a frash copy of mojave but it wouldn't complete :(

my hard drive is now messed up and I can't work out how to get it to a state where I can install an OS
in disk utility I see this and I can't erase the disk images or do anything that gives me a fresh empty disk

if someone could tell me how to get my mac to boot to factory settings or similar (preferably for catalina but any version of osx will do) i'd be super grateful
it's a 2015 macbook pro 15 - I did have a 60gig partition for boot camp but don't want that now.
IMG_4787.jpg
 

profmatt

macrumors 68000
Mar 7, 2015
1,601
1,563
UK
This happened to me, pretty much. I restarted my Mac, with command-R, which starts it in recovery mode. I then chose the option to install a fresh version of MacOS (it goes with whatever you had before, so not Catalina). That worked out. I then freed up some disk space (which had been the issue) and tried installing Cataline again. That worked fine.
 

Ultra Male

macrumors regular
Mar 10, 2018
184
46
When I clean installed, I only deleted all the partitions under Internal not Disk Images, I didn't touch that. Then I reinstalled the OS, it installs the latest OS which was there last so in my case it was Catalina as I upgraded the moment I got my MacBook Pro today as it was on Mojave then quickly wiped the disk again after the upgrade was done and then when I chose to reinstall the OS from the internet, it was downloading Catalina.

PS: I did ensure to format in APFS