Have MKV files appear as Movie files in Finder

Discussion in 'OS X Mavericks (10.9)' started by sweejin, Jul 28, 2014.

  1. sweejin macrumors member

    Joined:
    Aug 21, 2011
    Location:
    London, UK
    #1
    I'm running OSX Mavericks, and under Finder, when the files are sorted according to "Kind", i noticed my MKV files are put under the "Other" heading while MP4 and AVI files are recognised and placed under "Movies" heading.

    Is there any way to have my MKV files recognised and placed with the rest of my Movies files? Thanks!
     
  2. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #2
    If I sort my movies files according to "Kind", the mkv films are put under the "Movies" heading along with mp4/avi etc.

    Try dragging the com.apple.finder.plist file ( incl any with numbers & letters after it like com.apple.finder.plist.5bdEPxN ) from your User /Library/ preferences to the Trash & then do a restart.

    The Finder preferences will be reset to default, so you will have to reset them to your liking.
     
  3. sweejin thread starter macrumors member

    Joined:
    Aug 21, 2011
    Location:
    London, UK
    #3
    i tried what you advised, however, after rebooting, it didn't resolve the issue. i read from others running Mavericks that their MKV files do appear under Movies heading as well. i wonder if it's because i haven't have some form of MKV plug-in installed....?
     
  4. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #4
    You say " I haven't have some form of MKV plug-in installed...." Does that mean you do or don't ?

    If you have a plug-in installed - delete it & see if that changes things.
     
  5. sweejin thread starter macrumors member

    Joined:
    Aug 21, 2011
    Location:
    London, UK
    #5
    i'm sorry if i didn't make it clearer; what i meant was i didn't have any plug-in installed.

    so, do you have any other suggestions or ideas why my MKV files don't appear together with my other Movie files?
     
  6. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #6
    Have you tried creating a new user on your mac ?
    If not - copy an mkv film into the shared folder ( Mac HD/Users/Shared) and then create a new a/c.

    when you've switched to the new a/c you can copy the movie from the shared folder into 'movies' of the new a/c & see if you have the same problem.

    At least then you will know whether its a problem in your present user a/c or deeper within the OS.
     
  7. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #7
    Guessing that won't do anything.

    "Kind" is defined via the system UTI definitions at:
    /System/Library/CoreServices/CoreTypes.bundle/Contents/Info.plist

    Pretty sure Apple does not define mkv by default. So, app(s) need to define the type in their Info.plist.

    For example, VLC defines mkv, but defines its "Kind" as "Matroska Video File":
    [​IMG]

    [​IMG]

    So, either none of the installed viewing tools declares mkv, or, they've defined it as something else.

    One can mess with the system UTI file or manually edit an app's Info.plist. Left as an exercise since I've not messed with these directly myself.
     
  8. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #8
    The suggestion to try a new user a/c was to see if there was anything interfering with his present a/c. If the problem does NOT arise in a new user a/c, then that narrows down the search a bit.

    As it appears that the default ( i.e. mkv files being labelled under 'movies' - not 'others" ) seems to be working for myself and others - it is possible that something is not right with his user a/c.

    One should not have to mess with the system files or manually edit an app's Info.plist file, for a default setting to work. Thats why its called 'default'.

    One can get into all sorts of other trouble by changing system files, if one doesn't really know what one's doing.
     

Share This Page