Have they "fixed" Messages in Mavericks?

Discussion in 'OS X Mavericks (10.9)' started by spaceballl, Aug 12, 2013.

  1. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #1
    On the one hand, I LOVE Messages. On the other hand, it constantly puts my iMessages out of order, it says I have unread messages when I don't, and yesterday for a while, it had the nerve to tell me I had "-1" unread messages for a bit. For people with the beta, does it still act this way?
     
  2. ironman159, Aug 12, 2013
    Last edited: Aug 12, 2013

    ironman159 macrumors regular

    ironman159

    Joined:
    Aug 30, 2008
    Location:
    Costa Rica
    #2
    From what I've seen (currently on DP5), Messages no longer has memory leaks; it used to eat SO much memory it was nerve-racking.

    On the "messages order" issue I think it's finally fixed, the app no longer makes a mess out of my conversations. The only issue I have right now is that no matter what I do, messages sent to my phone number don't show as a notification, I have to manually open the app to get those, even though messages sent to any of my emails produce an instant notification.

    This bugs me because I want to deal with the actual app as little as possible, only reading the notifications and responding from there.

    At this point I just wish that Apple would re-write the app, or something, because in Mavericks it's bearable, on Mountain Lion is was downright unusable. I hope future DPs and even the GM show some improvements here.
     
  3. ATC macrumors 6502a

    Joined:
    Apr 25, 2008
    Location:
    Canada
    #3
    I can only speak of my own 10.9 install, but it's still buggy in DP5 for me. I get the same issue you describe (but not all the time, it seems intermittent), and I also have missing messages and the occasional unread messages (that are read already on another device).

    iCloud syncing on the whole hasn't been perfect in 10.9 (again, just from my own experience). I'm experiencing a weird Reminders bug where the Reminders app in 10.9 would show an overdue reminder (that I already checked as completed on my iPhone hours ago) and if I click OK on the reminder (you have two options, OK or Snooze) strangely that reminder's status changes on my iPhone from compete to overdue and incomplete. Very frustrating.
     
  4. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #4
    I get notifications from messages sent to my number. The way I have it set up is like this:

    [​IMG]

    I have my email set to not accept messages, so my phone number is the only way to accept messages.
     
  5. ironman159 macrumors regular

    ironman159

    Joined:
    Aug 30, 2008
    Location:
    Costa Rica
    #5
    Well, I also have my phone number activated in those settings, and the messages do arrive, but only when the app is open, so I assume it's not a problem about the settings itself, just that message notifications regarding my phone number, don't appear.

    I'll repeat it again, this app is perhaps the worst Apple program ever. I don't know why, oh god why, it's been so buggy from the start.
     
  6. jdmoore81 macrumors newbie

    Joined:
    Aug 13, 2013
    #6
    help

    i get a you can be reached at screen then i hit done then all it does it sit at the loading screen
     
  7. heyadrian macrumors member

    Joined:
    Aug 14, 2011
    #7
    Buggy? it's in beta :D That's probably why.

    In terms of your messages 'not arriving' when you're not signed in, there is a reason for this; well several.

    1) When an iPhone registers with the messages server, it first registers its number, which then the messages server associates with your email addresses as 'other means of contact'. if the primary means, i.e. your number, receives the message, as far as it's concerned, the message has been received.
    2) When a non 3G iPad logs into the messages server, it then registers itself with your Apple ID. making the Apple ID the primary means of contact. Ditto for the rest in (1)
    3) If both were offline and:
    i) Person A were to message your mobile number
    ii) Person B were to message your Apple ID
    --Whichever device logs in first, because the messages server didn't register the message as 'received' it will broadcast BOTH to whichever logs in first (as the Mobile Number and AppleID are linked) ergo marking the message as delivered

    4) If you have, 'Sync Documents' enabled on ALL of the devices, this will also sync the iMessage caches with one another. It won't remember if you've read it on one and not the other, it just remembers that 'its been read'

    Anyway, hope this helps!

    Cheers,

    A
     
  8. ironman159 macrumors regular

    ironman159

    Joined:
    Aug 30, 2008
    Location:
    Costa Rica
    #8
    It's been buggy since Mountain Lion, no need to call for the usual "it's in beta" phrase ;)

    I understand what you said, but I don't read any messages on my phone, and Mavericks still *won't* notify me there's a new message sent to my number. Clearly what should happen is that the server notifies every device associated to the phone number, the devices online will get the notifications, and IF any device reads the message, it's marked as read.

    Anyway, that's not my problem here, it's just that the notification won't appear on my MacBook, even though my laptop is set to receive any messages received to my phone number. This may as well happen because Mavericks as a whole is still in beta, but given the history regarding iMessage on OS X, I wouldn't get my hopes up.
     
  9. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
  10. heyadrian macrumors member

    Joined:
    Aug 14, 2011
    #10
    lol I've never had an issue :D I often rely on the fact that people iMessage me to my desktop :D I hate typing on the phone :D In short... I'm lazy haha :D

    If its not working with your mobile number, for the benefit of others in Messages:

    1) Click on the Messages Menu
    2) Click on Preferences
    3) Click on the Accounts Tab

    on the right you will see:

    "you can be reached for messages at" followed by a list of email addresses and your number.

    Make sure the number is checked.

    in your case @ironman. Uncheck it, exit messages, go back in, check it again and iMessage your own number from your phone and it should flash up. But i agree, messages is buggy, but it's better than nothing :D I mean not even BBIM is on the desktop yet so I guess we should just grant ourselves as being lucky :D
     

Share This Page