Having 2 Gmail accounts in Mail.

Discussion in 'Mac OS X Lion (10.7)' started by Merks, Mar 20, 2012.

  1. Merks macrumors newbie

    Joined:
    Jul 9, 2011
    #1
    Alright guys,

    I have two gmail accounts in Mail. One is for friends/people, one is for websites, etc and also my Apple ID. Let's say one of them is called Apple@gmail.com and one is Mac@gmail.com.

    Mac@gmail.com is my apple ID, while Apple@gmail.com is my other email. No matter what settings I have it on, every email I send out gets sent from Mac@gmail.com. I've tried everything, even just keeping Apple@gmail.com as the ONLY mail account in it, and things still get sent out through Mac@gmail.com.

    Has anyone else had this issue?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    You can choose what e-mail address you send messages from. There's a little drop-down menu in the Compose window.
     
  3. Merks thread starter macrumors newbie

    Joined:
    Jul 9, 2011
    #3
    That's the issue, I've done this, and they STILL send from only the other one... I don't get it...
     
  4. HeadlessChief macrumors newbie

    Joined:
    Apr 23, 2012
    #4
    I figured out how to fix this issue! :)

    The issue is that according to MacMail, you are using the same outgoing Gmail smtp server, so you need to differentiate the two.

    Go to Mail > Preferences

    In your accounts, click the drop down that has Outgoing Mail Server (SMTP), and click "Edit SMTP Server List...".

    When that window comes up, you'll see two different entries for Gmail, with the same outbound SMTP. Click on them individually, and you'll see the different Gmail account credentials. Change the description of each (I changed mine to my and my wife's names, to easily identify which SMTP went with which mail account) and ensure that your Gmail credentials are accurate. Click OK.

    Now, under each of the Gmail accounts, change the Outgoing Mail Server (SMTP) drop down to match each of your Gmail accounts, and click the "Use only this server" box.

    That should fix your issue! :)

    Nick
     
  5. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #5
    Also, in Mail preferences under Composing, make sure "Send new messages from:" is set to "Account of selected mailbox" to make it more likely the selected From account is the correct one.
     

Share This Page