Having issues with partition on external drive

Discussion in 'Windows, Linux & Others on the Mac' started by EricT43, Jul 10, 2013.

  1. EricT43 macrumors regular

    Joined:
    Oct 5, 2011
    #1
    I have a 2012 rMBP with a 256GB drive, on which I've installed Windows 8 into a 45GB partition. I use a Thunderbolt display, to which I have connected a 1TB external Firewire 800 disk drive. I use that drive to store my iTunes library and such.

    Well, I would like to install some additional software under BootCamp, but my BootCamp partition is almost full, and I really don't have the space to expand it. So my idea was to create a partition on the external drive for Windows, and install the software on that.

    I shrank the Mac OS X Extended Journaled parition on the external drive from 1TB to 900GB. Then in Windows, I created a new NTFS volume. When I tried to format the volume, the drive would disappear from Windows. I had to disconnect and reconnect the drive to make it appear again. But every time I'd try to format it, it would disappear.

    When I booted back into OS X, I found that both partitions on the external drive had been wiped out. I tried to repair with Disk Utility, but it didn't work. I had to reformat the partitions and recover my data from my Time Capsule (thank god for that). This time I formatted the Windows partition with ExFAT from Disk Utility.

    When I booted into Windows, it now recognizes the partition, but I'm still getting some flaky behavior. I'm trying to install Steam to it, and it keeps crashing during its update process.

    TL;DR - I'm having issues with a Windows-accessible partition on a previously Mac-exclusive FW800 drive. Is there something I'm missing in setting this up?
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    OS X for whatever reason has some major problems with the exFAT file system if you use Disk Utility to create such a partition. Try formatting the drive with exFAT in Windows and use a cluster size of 1024. That should allow the partition to be read from and written to in both OS X and Windows without any problem.
     
  3. EricT43 thread starter macrumors regular

    Joined:
    Oct 5, 2011
    #3
    I can try that again when I get home. But as I mentioned, when I tried to format from Windows, the drive would unmount. I tried both with NTFS and ExFAT.
     
  4. EricT43 thread starter macrumors regular

    Joined:
    Oct 5, 2011
    #4
    I just tried to format the drive again from within BootCamp as NTFS and I got the same result - drive dismounted and the format failed. After unplugging and replugging in the drive, the volume appears again, but now it is unformatted according to Windows. :(

    Any ideas on how to fix this?

    ----------

    OK just for giggles, I unplugged the drive from the FW port on the ATD, and plugged it instead directly into the USB 3.0 port on my rMBP. And guess what, the format worked with no problems!

    So, it appears to be a Firewire issue, or Thunderbolt issue. I'll report this to Apple support and see what they say. I'll continue to update this thread if I get anywhere with it.
     

Share This Page