Having problem with FireWire on external hard drive

Discussion in 'Mac Basics and Help' started by iBookG4user, Feb 2, 2008.

  1. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #1
    I bought a 500GB external hard drive a couple weeks back and it has been working flawlessly until today. I noticed that it was not visible on the desktop earlier, so I went to Disk Utility to mount it and was greeted with an error and told to use first aid on it. I subsequently repaired the disk and was greeted with "filesystem verify or repair failed".

    I'm now thinking "Oh great, I've got another failed hard drive", so just as an added precaution I connected the hard drive via USB and it worked perfectly. I then tried FireWire again and even tried to hook it into the other FireWire port on the hard drive, but it was to no avail. So, what's up with this? Is the FireWire in my external hard drive shot?
     
  2. Dave.S macrumors newbie

    Joined:
    Jan 27, 2008
    Location:
    Tirley, Gloucester, UK
    #2
    External HDD Probs

    This has been an issue with my machine as well.(G4 MDD). Drive works fine under USB, but with Firewire not a chance. Tried everything, gave it to some computer geeks to sort out and still no firewire so I leave it as usb. Sorry I've no better news to tell you.
     
  3. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #3
    When you say it works "perfectly" with USB did you try running first aid in Disk Utility on it when connected that way and it showed no errors?

    Do you use Time Machine? I have experienced some problems with my own Firewire 400 external HD when using Time Machine including a few times where it hosed the drive and ONE where I had to use DiskWarrior to eventually repair. I had not thought of connecting to the USB to try the repair. As far as the file system of the hard disk in question is concerned it is the same no matter how you are connecting it to your Mac.
     
  4. chilipie macrumors 6502a

    chilipie

    Joined:
    May 8, 2006
    Location:
    Englandshire
    #4
    Coincidentally, I had a very similar problem yesterday. It was fixed simply by changing the FW cable! :eek:
     

Share This Page