Having problems... Jailbreaking 3GS firmware 3.1.2 old boot rom.

Discussion in 'Jailbreaks and iOS Hacks' started by wRek, Nov 16, 2009.

  1. wRek macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #1
    Alright... So, my wife and I both have 16gb 3GS'. Both running firmware 3.1.2. We were both previously jailbroken on 3.0 and even older... I also have an original iPhone that has been jailbroken on numerous firmwares.

    The problem... My wife's 3GS had some problems, and was sent in and replaced by Apple with a new one. The new one came factory with 3.1.2, and after checking has the boot ROM = iBoot-359.3. It was my understanding that I should be able to do an un-tethered jailbreak since it has 359.3 and not the newer 359.3.2? Did I misunderstand?

    I have now tried to jailbreak the phone using PwnageTool 3.1.4 as well as Blackra1n. Neither have worked. On Blackra1n it appears to work until the phone reboots, and instead of starting back up and allowing me to go to the home screen and launch the program, the phone just goes into recovery mode and opens iTunes. with PwnageTool I begin installing the custom IPSW in DFU mode, and I get a failure message.

    Kinda getting frustrated, so any help is VERY MUCH APPRECIATED.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Try installing the IPSW with recovery mode to see if that makes a difference.
     
  3. wRek thread starter macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #3
    I will try right now.
     
  4. wRek thread starter macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #4
    Got the same exact error...

    The iPhone "iPhone" could not be restored. An unknown error occured (1604).
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    Hmm have you tried a different usb slot? Make sure you are downloading your pwnage tool from here.
     
  6. wRek thread starter macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #6
    Yep, tried a different USB port, and the PwnageTool I'm using is the same one I used to jailbreak my own phone when I upgraded to 3.1.2 which was download downloaded from the official DevTeam blog. :(
     
  7. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #7
    Have you tried using a different computer to jailbreak it? That might help. Or reinstall iTunes and then try installing the custom IPSW again.
     
  8. wRek thread starter macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #8
    I might try that tomorrow... My wife is getting tired of me messing with her phone for the night. haha.

    Tomorrow I will download PwnageTool to her MacBook and try it.
     
  9. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #9
    You've been successful in the past, I'm sure you'll figure it out. We're pulling for you! (So is your wife so you'll stop ***** with her phone!).
     
  10. wRek thread starter macrumors member

    Joined:
    Sep 6, 2009
    Location:
    WA state.
    #10
    I still haven't figured it out. :( It's probably something stupid, and I'm going to feel like an idiot once I figure it out...
     

Share This Page