iPhone XS Max having problems sending non-imessage texts on wi-fi. Please help!

Discussion in 'iPhone' started by Damn Dirty Ape, Jun 12, 2019.

  1. Damn Dirty Ape macrumors regular

    Damn Dirty Ape

    Joined:
    Feb 23, 2010
    Location:
    Illinois
    #1
    XS Max updated to latest. About half the time on wi-fi at home if I try to send a non-imessage text (green)it will come up and say it has failed and then I can try to re-send. It is completely hit or miss if these texts go out.

    I have tried:

    reset network settings
    set up phone as new
    tried linksys router
    tried netgear router

    Apple of course blames the router and verizon, verizon blames apple and or the router. You see how it is going. If I take the phone off wi-fi of course there are no problems.

    Hoping someone can suggest something?
     
  2. posguy99 macrumors 6502a

    Joined:
    Nov 3, 2004
    #2
    Maybe I 'm missing something, but what would a normal SMS text message have to do with whether the phone has a wifi connection or not?
     
  3. Damn Dirty Ape thread starter macrumors regular

    Damn Dirty Ape

    Joined:
    Feb 23, 2010
    Location:
    Illinois
    #3
    well in this case it wil send on lte but not on wi-fi. So something is stopping it.
     
  4. Jimmy James macrumors 601

    Jimmy James

    Joined:
    Oct 26, 2008
    #4
    I tried to make a call on nfc. What am I doing wrong?
     
  5. rijc99 macrumors 6502a

    Joined:
    Apr 27, 2015
    #5
    Is “Send as SMS” turned on?
    --- Post Merged, Jun 16, 2019 ---
    Have you tested it at a different WiFi locations? At least then you’ll be able to isolate whether it’s all WiFi locations or just yours.
     
  6. macfacts macrumors 68040

    macfacts

    Joined:
    Oct 7, 2012
    Location:
    Cybertron
    #6

    Make sure iMessage is off. Apple makes it tricky to turn off to keep you locked in.
     
  7. riteshritesh macrumors member

    Joined:
    Mar 18, 2016
    Location:
    Mumbai INDIA
    #7
    It has nothing to do with wi-fi. Infact turn off wi-fi and check if your text goes through.
    If no, then check under Settings>Messages and if Send as SMS( Maybe Text under US settings) is toggled on.
    Also check under Send & Receive and see if your phone number is ticked there.
    --- Post Merged, Jun 17, 2019 ---
    Ignore my message. Didn't read that it works when not on wi-fi. It must be something with your router, if it works on someone else's wi-fi connection.
     
  8. Damn Dirty Ape thread starter macrumors regular

    Damn Dirty Ape

    Joined:
    Feb 23, 2010
    Location:
    Illinois
    #8
    I have now tried 3 router brands and all produce sporadic random non-send of non-imessage texts. Checked all the settings I can find.
     
  9. joeblow7777 macrumors 603

    Joined:
    Sep 7, 2010
    #9
    I think other people have said this, but if it's not an iMessage it shouldn't have anything to do with wi-fi or data/LTE. SMS messages are sent through your carrier, just like phone calls.

    I feel like we're all missing something here.
     
  10. Ruggy macrumors regular

    Joined:
    Jan 11, 2017
    #10
    I know you've tried multiple routers but it really does sound like a typical router problem.
    They always have a hardware firewall in them and it is typically what happens when a port isn't open, or you are using bridge mode or the router firewall is blocking the connection for some reason.
    Especially if you can do it from other wifi services then it can't be anything on the phone.
    I would go into the router settings and start by disabling the firewall and if that works, gradually re-enable. Also check that the ports used by imessage are all enabled. I know it uses 80 and I'm petty sure that will be enabled, and 443 if you use imap, but I would look into that.
     
  11. posguy99 macrumors 6502a

    Joined:
    Nov 3, 2004
    #11
    Because it doesn't have anything to do with your router.
     

Share This Page

10 June 12, 2019