Having problems upgrading to 1.1.2 on OTB 1.1.3 iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by mikelong622, Feb 10, 2008.

  1. mikelong622 macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #1
    I have successfully downgraded to 1.1.1, jailbroken and installed oktoprep, and when i go to install the 1.1.2 firmware i get an error in itunes and then try to run Jailbreak.jar and it doesn't connect to my iPhone. Can anyone PLEASE help me out. I have been stuck on this for almost 12 hours now and yes, I have tried google searching.
     
  2. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #2
    Before we get onto your error - I hope you installed oktoprep before you tried to do the 1.1.2 upgrade!

    The error your getting is 100% down to itunes not liking your USB port - change USB ports or better yet change PC/MAC as for whatever reason sometimes it just WONT restore on the same PC.

    If you change PC/MAC then do the upgrade it WILL work and then you can run the jailbreak.bat...

    and before you ask about restarting your PC fixing the issue - it doesnt seem to - it just seems to work or not work when you update/restore!
     
  3. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #3
    Install octoprep, then reboot the phone. After that, make sure you UPDATE to 1.1.2 and not RESTORE. You cant run jailbreak.jar until you are actually loaded into 1.1.2. Jailbreak.jar doesnt work on 1.1.1, its to unlock 1.1.2.
     
  4. mikelong622 thread starter macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #4
    Yeah that is what I am doing, quitting itunes making sure i hit update etc etc. I am doing this on a mac. Are you saying I need to switch to a NEW computer to do it from?!?

    I think the problem is that the 1.1.2 isn't loading properly on the iPhone. I am getting an error in itunes that said it couldn't be completed Unknown error (1016). Similar to the one you're supposed to get after restoring to 1.1.1 except that one is (1015). Is that normal?
     
  5. cazlar macrumors 6502

    Joined:
    Oct 2, 2003
    Location:
    Sydney, Australia
    #5
    Also, what version of iTunes are you running? I had an issue with 7.6 kicking the phone into the wrong mode at one stage during the jailbreak, so did the jailbreaking from a different mac with 7.5.
     
  6. mikelong622 thread starter macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
  7. mikelong622 thread starter macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #7
    I got it!!

    Now let's just hope that this time when I DON'T skip the 1.1.2 firmware, it'll fix my ringtones, and my contacts and calendars, and my edge...are these all things that are fixed by not skipping 1.1.2? Or is there something else I need to do?
     

Share This Page