Having problems with SC2 CE USB flash drive.

Discussion in 'Mac and PC Games' started by jjp14, Jul 27, 2010.

  1. jjp14 macrumors member

    Joined:
    Jul 21, 2009
    #1
    One of the main reasons I opted for the the SC2 Collector's Edition is that I wanted the USB drive with SC1 and its expansion on a portable stick. I've also never played SC1, so I was going to play it before 2.

    Anyway, when I insert the USB drive into my '10 MBP, the read lights flicker for about 2 seconds and then nothing happens. The drive doesn't appear on my Finder, nor on my desktop. Now i'm sort of a real newbie to the Mac OS, so I don't really know much about how the OS handles flash drives.

    I came with a couple conclusions: the drive is DOA (doesn't seem too plausible); it's formatted in a way that Mac can't read; or i'm just missing something completely obvious.

    Hopefully someone else with the CE can chime in with a solution, or confirming the bad news.

    Thanks.
     
  2. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
    #2
    Did it also come with a CD Key for SC1 and Brood Wars? If so you could attach them to your Battle Net account and download the games from Blizzard directly. Not ideal maybe but an alternative method.
     
  3. OiCecil macrumors newbie

    Joined:
    Oct 1, 2009
    #3
    I got the collectors edition too purely for the original game! Haven't played it in years, really takes me back.

    Anyway I can say it fine for me, so it sounds like a bad memory stick. Have you tried it on a Windows pc? If it still doesn't work then just call or email Blizzard for a new one :)
     
  4. OiCecil macrumors newbie

    Joined:
    Oct 1, 2009
    #4
    I couldn't see the serial keys written down anywhere for mine. When I installed they were pre-entered in the installer, so it seems like the only way to recover the serial is to actually use the installer... =/
     
  5. BigYellow macrumors member

    Joined:
    Dec 19, 2006
    #5
    This is probably glaringly obvious, but have you tried loading it up on another machine?
     
  6. imassents macrumors 6502

    Joined:
    Jul 3, 2008

Share This Page