Having SERIOUS PROBLEMS with my Jaguar 10.2.8 Update install!

Discussion in 'Mac Apps and Mac App Store' started by SuperbBoy, Mar 11, 2004.

  1. SuperbBoy macrumors newbie

    Mar 11, 2004
    Heya everybody... i'm a newbie here... i just signed up, and i did a search, and all i found out was that Apple pulled their 10.2.8 updates back in September, which i'm guessing has NOTHING to do with me, because i just downloaded and installed this (new) update the other day.

    So i thank you in advance for helping me, and i'm going to be thorough in order to minimize questions which would slow down the process of getting this problem solved. Again, thanks for your time. :)

    So here's the 4-1-1....

    I am running Jaguar on my 450mhz G4 tower. Jaguar has been doing great, so i guess i shouldn'ta messed with it, but i got tired of "Software Update" nagging me to install a buncha updates, so the other day, i finally did it. So, i have a FAST DSL connection, it's 1 megabyte (megabit?) download speed, so corrupt downloads have NEVER been a problem before... until now. So i downloaded the following things (per Software Update):
    - Internet Explorer 5.2 Security Update (v5.2.2)
    - Mac OS X Update Combined (v10.2.8 Build 6R73)
    ...a 100MB download in itself
    - QuickTime (v6.2)
    - StuffIt Expander Security Update (v7.0)
    - iTunes (v4.2)

    i DIDN'T install a couple items that Software Update (SU) popped up: iMovie v3.0.3, since it required QuickTime 6.5, and after this update, i would only have QuickTime v6.2, so i thought i can update iMovie at a later date. also the iPod software update, since i don't have an iPod (yet). Having said all that, i was downloading everything, it was taking a LONG time, and then, halfway through the download, it kept popping up messages like "couldn't install all the updates, select Download To Desktop and try again" or something like that. i couldn't quit and start over at any point, so i let SU do its thing. it ended up installing everything but the 10.2.8 update, so after i restarted the computer, then i downloaded the 10.2.8 Update PKG file to my desktop. I then installed it and restarted. Then, SU popped up MORE updates...

    - Graphics Driver Update (for the DVD Player)
    - iCal
    - Java 141 Update1
    - Security Update 2003-12-05
    - Security Update 2004-01-26
    - Security Update 2004-02-23

    So i downloaded all THOSE PKGs to my desktop, and then installed them. Okay, so i restarted the computer one last time, and here's where it gets crazy.

    So now, thinking that everything should be running tip-top, everything ends up turning to pure crap. I open up my shiny new iTunes, and it crashes after about 20 seconds. Not just a little "Application Has Quit", it not only shuts down, but my entire desktop disappears, it gets replaced with a pure blue screen (the Mac equivalent of the Windows Blue Screen Of Death???), and after a few seconds, my desktop re-appears, and the iTunes is shut down. This process now happens with just about EVERYTHING. QuickTime, my Audion mp3 player, and the clincher: if i throw something in the Trash, same thing. This will happen over and over again, no matter how many times i re-start my computer. My Entourage, Safari, Internet Explorer, and LimeWire don't seem to crash the whole computer like this, or crash the computer at all, but like i said, the other stuff does. Oh, and my DVD Player won't even open AT ALL now (no blue screen there, it just won't open at all). So in short, everything i installed updates for, now doesn't run at all or crashes the whole system. Nice. I looked on Apple's website, and they don't address anything like this. i looked all over the internet, and took some advice on other sites to clear out my caches. i got a little utility called "Cache Out X v4", installed it, and cleared out all my caches, but that didn't help at all. i didn't clear out my logs though, i thought those logs might help you fine people find out what happened? i dunno, cuz i'm just a graphics guy, not a tech guy.

    Soooo... anyone know what i can do to fix this fine mess i've gotten myself into? The only things i can tell you about my computer's past, are this: i DO have a now expired ShapeShifter OS theme changer on my system, but i don't think that has anything to do with any of these problems, and i DO use LimeWire, it runs slow, always has, and it Quits on its own a lot, but i hear lotsa Mac users say that, so i don't think that's an issue either.

    Lastly, please give me ALTERNATIVES to re-installing my whole OS. When i installed Jaguar last year, i did a clean install, and i don't have OS9 anywhere on the computer (not even on it's own partition), it's ONLY OSX 10.2 Jaguar. i have all my important stuff backed up onto my second hard drive, so if i NEED to re-install the OS, i CAN, buuuuut... i fear that if i DO re-install, once i do the updates (again), that i'll have the same problems all over again, since the root of the problem was never addressed.

    So thank you in advance for reading all of this babble, and thank you even more for your help.

    Your fellow Mac enthusiast (until the other day),

  2. HexMonkey Administrator


    Staff Member

    Feb 5, 2004
    New Zealand
    Try repairing permissions if you haven't already. Go to Application/Utilities/Disk Utility, select your hard disk and click 'Repair Disk Permissions' (it might be slightly different because I use Panther).
  3. SuperbBoy thread starter macrumors newbie

    Mar 11, 2004
    Well Hex, you're on the right track...

    First of all, thanks Hex for a speedy reply, i really appreciate it. it's weird to think that i'm here in San Diego California, and someone halfway around the globe in KiwiLand is helping me out. Crazy!

    Anyway, i ran the Disk Utility like you said, and it said that i can't do any Verification on a boot disk, so i got out my original install CD's, and booted off of the CD, then ran Disk Utility from there.

    When i verified the hard drive, it came up with errors.. so i ended up Verifying the disk, the permissions, and then repaired the disk AND did Repair Permissions. In other words, i tried everything. Every time i tried to repair something, once i restarted the computer like normal, i still have all the same problems in my OS. To top things off, every time i start the OS off of the CD-Rom, it always says the same thing in Disk Utility when i do Verify Disk, that there are a wrong number of blocks in a certain temp file. Why won't it ever repair it? it SAYS that it's repaired every time i run the "Repair Disk", but then i restart, and i have the same problems in the OS (when i don't boot off the CD), and then i go back to booting off the CD, and same problem again. I'm running in circles.


    So it definitely looks like the root of the problem is with the physical data on the hard drive, but is there a way to repair it? or should i competely erase the disk, and then install the OS on a clean hard drive? is that my only choice at this point?

  4. HexMonkey Administrator


    Staff Member

    Feb 5, 2004
    New Zealand
    I'm not sure what the problem is then, but if it's a software problem then formatting and reinstalling will fix it (I'm not saying that you should do this yet though). If it doesn't fix it then there's probably a hardware problem and you'll need to get it the computer checked.

    Since there's problems repairing the disk, I doubt the problem is user specific, but try using a new user anyway, as you may have two separate problems. If that doesn't fix the problem and you have enough disk space available, try a reinstall with the archive and install option. This keeps all your data, and archives the old system by putting it in a folder called 'Previous Systems', so you can recover it if necessary. If the new system works (even before updates), then it would have probably been a problem with the old system. Install the updates and hopefully all will work properly. If it doesn't, it may be necessary to do a clean install (unless someone else offers a better solution first).

    Someone can correct me if necessary, disk problems aren't my specialty.

Share This Page