Having SEVERE trouble with pwnage jailbreak Original 2g iphone

Discussion in 'Jailbreaks and iOS Hacks' started by saamajaama, Sep 1, 2009.

  1. saamajaama macrumors newbie

    Joined:
    Sep 1, 2009
    #1
    Complete history: Bought unlocked iphone from a friend. worked perfectly fine except that he had installed Cydia AND Icy during jailbreak so Cydia wasn't functioning properly. I was told the only way to fix this was to redo jailbreak and not install Icy. Tried to do this myself and have only regressed for the past 2 days. iPhone needs to work with T mobile SIM, and have only been successful doing so once, only to completely botch this after updating 3.0 software through itunes (did this to restore form backup). now pwnage wont browse the correct bundle, restoring to custom firmware wont work due to "error 1600." This is a complete mess. I have been researching for 2 days trying different procedures, and now im afraid I've taken steps backwards. Can this be fixed. Step by step would be so helpful
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    Have you updated your Pwnage Tool or downloaded Redsn0w 0.8? Personally, I would make sure your iPhone has 3.0.1 on it, then use Redsn0w 0.8 combined with the 3.0 firmware:
    http://www.iclarified.com/entry/index.php?enid=4304
     
  3. saamajaama thread starter macrumors newbie

    Joined:
    Sep 1, 2009
    #3
    I did update pwnage tool, I'm not familiar with redsn0w. And I'm confused about updating the software on my iphone. Its kind of limbo right now. Its not activated as I said I have T mobile and have been unsuccessful with jailbreak. Should I just restore it from itunes?
     
  4. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #4
    you need to jailbreak your phone - no way around it. I suggest you use redsnow because it's quite a bit easier to use than pwnage tool - by the sounds of it you're not sure about what you have to do. So redsnow will be a lot easier to use for you. if you've been following the iphone dev team for a while, redsnow is the new quickpwn... does that ring a bell?
     
  5. saamajaama thread starter macrumors newbie

    Joined:
    Sep 1, 2009
    #5
    Unfortunately I have no idea what all these terms are, I only just became familiar in the last 2 days because of this whole mess. I sincerely appreciate the replies to this thread because I am completely clueless! Anyhow, I currently running redsn0w and am stuck in "waiting for reboot" screen.. nothings happening, and my guess I went wrong in the first step: restoring the iphone (whats the result? is my iphone left in restore mode? cuz thats what happens after it asks for SIM) OR DFU mode, this is a problem because once iphone is off, attempting to enter DFU mode results in the iphone turning on to fast and then screwing up DFU. ALSO itunes keeps closing randomly?
     
  6. saamajaama thread starter macrumors newbie

    Joined:
    Sep 1, 2009
    #6
    iphone up and running! Everything is great. Thank you so much for your help. Ok, just one more question. In itunes, it says a newer version of iphone software is available (3.0.1) I do NOT want to touch that correct?
     
  7. BennyJet macrumors newbie

    Joined:
    Jan 26, 2009
    #7
    Correct :) I too am on T-Mobile UK with a 2G, the 3.0.1 will remove your sim unlock.

    It's a pretty pointless update anyway - it just fixes an SMS vulnerability for people who enjoy texting their bank details and sexual preferences.
     

Share This Page