Having the weirdest problem. Finder or Any/All Apps Fail to Open

Discussion in 'macOS' started by nersveen, May 31, 2010.

  1. nersveen macrumors newbie

    Joined:
    Mar 3, 2008
    #1
    I just turned on my 20-day old 17" MacBook Pro Unibody and nothing happens other than a LONG boot sequence. The Finder isn't even indicated as running in the dock, and the only thin the conputer is capable of is opening a few select windows. Every time I attempt to run an app, I get the following warning: You can't Open the Application (null) because it may be damaged or incomplete. That's all the computer can do. I tried to launch Onyx to clean out the baffels, but it just won't launch. The computer only shuts down or restarts by holding the power key down. Any Ideas Anyone? I need help. Thanks for any advice or suggestions.

    Happy Memorial Day
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Repair your permissions via Disk Utility and the Mac OS X installation DVD that came with your Mac.
    If that doesn't work, try to reinstall Mac OS X and see if that works.
    If that does not work, erase the HDD via Disk Utility and install Mac OS X again, but save your personal data first if you can.


    Should I start up from a Mac OS X install disc to repair disk permissions?

    When possible, disk permissions should be repaired while started up from a Mac OS X volume (hard disk) that contains Mac OS X, instead of a Mac OS X installation disc. Mac OS X software updates may change permissions on some files to improve security. When this occurs, the version of Disk Utility on the Mac OS X volume is updated to account for the new permissions. Running Disk Utility while started from the Mac OS X volume ensures that the changes made by software updates are preserved.

    Mac OS X v10.6 Snow Leopard notes:

    In Mac OS X v10.6.x, Disk Utility can only verify/repair permissions of other Mac OS X v10.6.x disks. If you need to verify/repair a Mac OS X v10.5.x or earlier Mac OS X version, you will need to use a Leopard or earlier disk.
    You don't need to repair disk permissions prior to installing Mac OS X v10.6 over a previously-installed OS. The Installer will do this automatically.


    from http://support.apple.com/kb/ht1452
     
  3. stacefavoch macrumors newbie

    Joined:
    Jul 23, 2013
    #3
    Similar Issue

    I have the same issue as the OP. I will be the first to admit that though I am more computer savvy than the average person, I am NOT nearly as advanced as most of the people on here. I have never done a Permissions Repair. My essential question is this: I inserted my Install DVD, booted the computer, and ran Repair Disk Permissions. I do not think it repaired everything, as a few of the lines read "...and will not be repaired." I now want to take the DVD out and boot my computer normally to see if anything has changed - but silly as it is, I'm stuck. I know the wrong button will erase my HD and I really don't want that to happen. So how do I proceed from here?

    Here is my detailed story of how I got here in the first place:

    I went to use my Macbook (2010 white unibody, running OS 10.6.8) and I noticed I couldn't open anything. I tried to restart, but it wouldn't proceed, so I manually turned off and turned back on my system. I noticed it was a touch slower in the startup, and a blue screen appeared in between the initial white screen and my desktop. I don't recall there being a blue screen ever before, but if there was, it was never long enough to notice it. At my desktop, it took longer than usual to become ready to use. I tried opening Google Chrome first, and nothing happened. I then tried clicking on a few apps in my dock, and none would open except Finder. I closed the Finder window, tried to do a restart again and it still wouldn't power down on its own. I did another manual off/on, and the startup took even longer.

    The same situation happened - a blue screen for a few seconds, then my desktop which needed an extra second or two to get functional, but then I'd click ANY app on my dock, and the dock would disappear for a second, then come back. I tried opening Finder, but I got an error message -10810. The error window wouldn't close, and if I tried opening another application, another error message window would open in front of it. The only quasi-functional part of my dock was my Downloads folder. I could open it in the dock but NOT in Finder. I tried opening a photo, but nothing would happen.

    My boyfriend, who is in general great with computers, but is not really familiar with Macs, did a bit of research and figures this is an OS issue. My goal now is to not lose all of my data. He suggested booting in Safe Mode, so I did that. I logged in, I still wasn't functional, but I read that sometimes
    just logging in with SafeBoot will clear some cache and yuckiness out. So I had to again manually off/on, and there was only two small changes: when I clicked Google Chrome, I got a message that said something along the lines of, "This is the first time you are opening this application.... if you'd like to continue, click open." I clicked open, and the window went away, but Chrome didn't open. The other change was now that when I tried to open Finder, there wasn't a coded' error message, it was simply a window that said something along the lines of "This application is not available." (I feel silly not remembering verbatim the error messages. I'm sort of in a panic about this).

    Something worth noting: I am still under AppleCare for another few months and I do have a Genius Bar appointment later today. I just wanted to see if I could take some steps first.

    Thanks in advance!!
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    If repairing permissions results in error messages, some of these messages can be ignored and should be no cause for concern.
    Simply reboot your Mac. You can eject the DVD by holding the mouse or trackpad button down while it reboots.
     
  5. stacefavoch macrumors newbie

    Joined:
    Jul 23, 2013
    #5
    Thank you so much. I did get the disk out with no issues.

    Except, my system is weirder than ever. Upon my reboot, the blue screen stayed even longer and my cursor appeared. Then my desktop loaded very slowly - the dock first, then 2 thumbnails I have on my desktop, then the command bar at the top - however, it took a while for the entire command bar to show; the flag, battery symbol, AirPort, etc were not immediately visible. Then the dock disappeared. Then it reappeared, and the command bar is currently completely missing. I didn't click anything.

    Does anybody have any suggestions? If not, I guess I will very anxiously wait for my appointment time!

    Thank you all so much.
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    One symptom of a failing hard disk is very slow disk reads. Basically, the disk is trying and retrying because the data is invalid, so it has to read and reread many times in order to succeed.

    Another symptom is disk errors. That is, data read from disk is wrong in some places. It isn't what was written to disk, and the disk controller can't correct it.

    Consider what would happen if those two symptoms existed. You'd get very slow program loading (slow reads), occasional program crashes (disk errors), and Disk Utility repairs wouldn't solve the problem.


    You should be thinking about how to get your data off the current disk and onto one that's known to be good. If the computer goes in for repair, they will not automatically backup your data. If you do ask them to make a backup, they will probably charge you for the time.

    If you make a backup of your data, you're prepared for the worst.
     

Share This Page