Having trouble activating iMessage on iOS7, anyone else?

Discussion in 'iOS 7' started by xolan99, Aug 21, 2013.

  1. xolan99 macrumors regular

    Oct 21, 2007
    I deactivated iMessage because of a bug regarding messaging from a friend and now I can't seem to reactivate it on iOS 7 (getting an error with activation)

    I tried my iPad 4 with iOS6 and was able to deactivate and reactivate there.

    Anyone else seeing this by any chance?
  2. batting1000 macrumors 604

    Sep 4, 2011
    Try resetting your settings.
  3. xolan99 thread starter macrumors regular

    Oct 21, 2007
    Did that, even tried restoring from brand new. Even as a brand new phone, I still can't activate.
  4. jnappleseed macrumors member

    Jun 25, 2013
    Athens, Georgia
    I'm having the same issue today. I've been trying for the past two hours to fix it but I can't. I was able to sign in on an iPod with my ID and it activated fine, so I believe that rules out an issue with the servers. Did you ever figure it out?

Share This Page