Having trouble deleting hidden file on USB?

Discussion in 'Mac Basics and Help' started by dakota1540, Sep 22, 2012.

  1. dakota1540, Sep 22, 2012
    Last edited: Sep 22, 2012

    dakota1540 macrumors newbie

    Joined:
    Sep 22, 2012
    #1
    I have a USB, and I have a movie file that is set to avi, and when I drag it to the trashcan and hit empty trash can, it takes me bake to the USB drive and says that the trashcan can not be emptied because the file is still in use. I have tried just putting the file back into the USB and unplugging it and then plugging it back and repeating the delete process, but that hasn't worked either. I also dragged the file into Terminal and used the rm command and it says

    "Dakotas-MacBook-Pro:~ dakotathompson$ /Volumes/Dakota/refill.pro.480.avi rm
    -bash: /Volumes/JUNEAU/refill.pro.480.avi: cannot execute binary file"

    I have tried everything that I can think of.

    The file is also only in Trash while the USB is plugged in.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Did you restart your Mac and tried emptying your Trash after that?
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    Where did you learn that command? Because it's backwards. It should be:
    Code:
    rm /Volumes/Dakota/refill.pro.480.avi
    
     
  4. kpgh554 macrumors regular

    kpgh554

    Joined:
    Dec 29, 2011
    Location:
    iver england
    #4
    have you tried just reformatting usb
     

Share This Page