Having trouble getting HD video to iMac

Discussion in 'iMac' started by danmc00, Oct 31, 2009.

  1. danmc00 macrumors regular

    Joined:
    Oct 29, 2009
    #1
    I just bought my 27" iMac and I recently purchased a Canon HF200 HD camcorder also. The camcorder records to a SDHC card. The first time I loaded video to the iMac, I just put the SDHC card into the SD slot on the side of the computer and it worked fine. It imported into iMovie great. Now when I insert the SD card into the slot, it just pulls up iPhoto. Even if there is nothing to import. I have video I just shot on the camcorder on the card. I tried using the USB cable that came with the camcorder also. I can load it to other computers, so I know the camcorder is recording just fine. Does anyone have any pointers for me? I don't know where to start.
    Best Buy recommended me using a firewire connection, but I can't find a firewire connection on my camcorder.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    You can import video to iPhoto as well and then copy it to iMovie if you want to edit it. I bought a Canon camera yesterday and been playing with it and I've used USB because I don't have SD slot
     
  3. danmc00 thread starter macrumors regular

    Joined:
    Oct 29, 2009
    #3
    That's the problem. If I take snapshots with my camcorder, they show up in iPhoto, but the video doesn't.
     
  4. danmc00 thread starter macrumors regular

    Joined:
    Oct 29, 2009
  5. zedsdead macrumors 68040

    Joined:
    Jun 20, 2007
    #5
    Try using the USB cable first, and see if iMovie recognizes it (there is no firewire on that camera). Let us know if this works.
     

Share This Page