Having trouble with encrypted SSD

Discussion in 'MacBook Pro' started by stonewall777, Jan 23, 2014.

  1. stonewall777 macrumors newbie

    Joined:
    Feb 18, 2010
    #1
    I formatted a new HDD as a mac extended journaled encrypted,
    and then tried to install os x 10.9 mavericks on it.

    It was so slow that I eventually gave up and canceled everything
    and reformatted the SSD as mac extended journaled.

    I have the password, and everything seemed to re-format OK.

    But now this drive seems as slow as before. I tried to reinstall
    mavericks, and I hung in there until everything was installed,
    but on boot up, the thing would sit there for many minutes. I
    didn’t time it but it was definitely not worth it.

    So, — am I missing something? Is there a super secret way
    to remove encrypted formatting from a disk drive? Perhaps
    a key combination to hold down while you’re doing all this?

    I reformatted the SSD as mac extended journaled, and put it in
    an external enclosure. And ran the Blackmagic speed test,
    and it show 72 write and 78 read, which I think is normal.
    I was using Firewire 800.

    So, — why is it so slow when trying to put os x 10.9 on it?

    Any thoughts?

    The drive is a Sandisk X110 Solid State Drive 256GB.
    And the computer is a macbook pro 15 mid 2009.
    (I realize this is sata 2)


    I went back to a mechanical HDD for the boot drive and it’s not at all
    slow in an unusual way, it seems normal, speed wise.

    Thanks in a advance.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You did things a bit backwards. You don't want to encrypt the drive then install Mavs. What you want to do it just dpi a regular Mac OS Extended format then install Mavs, then after that inside Mavs turn on Filevault encryption in the Security and Privacy panel of System Preferences.

    So let's see about undoing this.

    Attach the drive and start Disk Utility and tell me what it says at the bottom by "Format:" (mine looks different because I have Filevault turned on).

    [​IMG]

    If it is still encrypted, click on the file menu in Disk Util and select turn off encryption. After that is done select the drive band name at the very top above the Macintosh HD partition then go to the erase tab and format the entire drive as Mac OS Extended. Then try and install Mavs.
     
  3. stonewall777 thread starter macrumors newbie

    Joined:
    Feb 18, 2010
    #3
    This is what Disk Utility sees for my Sandisk SSD

    From Disk utility I see:

    Mount Point : /Volumes/Untitled
    Format : Mac OS Extended (Journaled)
    Owners Enabled : No
    Number of Folders : 19

    This looks like it’s a normal, non-encrypted format to me.
    So, I think everything is OK.

    Thanks very much.

    It turns out that I discovered something about my
    computer, macbook pro 15, mid 2009. These
    computers had some sort of firmware issue regarding
    the change from sata 2 to sata 3. The newest firmware
    is version 1.7, but installing this version causes drives
    to slow way down. The solution was to revert back to
    the earlier firmware. It’s in the google record.

    As luck would have it for me, I formatted the HDD as
    encrypted first, as described. And that kind of lead me
    down the path. But that’s why I was asking.

    So, I think I’ve solved this. It’s the firmware.
     

Share This Page