Having trouble with iPhone 3GS and Nike+

Discussion in 'iPhone' started by JW008, Jul 9, 2009.

  1. JW008 macrumors 6502

    Joined:
    Apr 29, 2005
    #1
    I'm having a pretty big problem with the iPhone 3GS and Nike+. Most of the time (thought, not every time) when I get close to my second mile the iPhone starts to automatically going to voice control or pausing the workout. As soon as I resume the workout or cancel Voice Control it immediately goes back to one action or the other making it nearly impossible to finish the workout.

    I thought it might be the Apple headphones (and I'm still not totally convinced it's not), but I exchanged them with Apple and I'm still having the problem.

    I'm not really expecting anyone to have a solution for this, but I did want to try and see if this is a bug on my specific iPhone or if anyone else was having the problem.

    Thanks!
     
  2. jasonc11 macrumors newbie

    Joined:
    Jul 9, 2009
    #2
    Nike + Issues w/ 3GS

    I haven't had the issues that you're discussing, however I can not get my iPhone to calibrate correctly. I've done a number of runs (on the run calibration setting) that exceed the 400 meters required to calibrate and after each the phone simply says "This run can not be used for calibration."

    Anyone encountered this, any advise on how to get it to correctly calibrate?

    I've even changed the direction of the sensor and done a total restore to the device.

    Thanks in advance.
     
  3. surfer99 macrumors 6502

    Joined:
    Jul 30, 2006
    Location:
    VA
    #3
    I dont have an answer for either of these problems but I can say that I have been having issues with Nike + as well. Mainly due to it not recording my workout. I will start it and when I finish the only thing that it will record is the time I ran, not the distance. What I found was that Nike+ has a really solid forum and that a lot of people are having the same issues that all three of us are having. I would suggest going there first for any Nike+ related issues.
     
  4. ericvmazzone macrumors regular

    Joined:
    Dec 9, 2008
    Location:
    Kalamazoo, MI
    #4

    Set it up to calibrate on a 2 mile run, find a track at a high school run 8 laps and hit end. That calibrates it. If you go further that it expects it'll not work, of course you may have a strange stride that throws it off, but I expect that you may be exceeding the 400 meter distance.
     
  5. JW008 thread starter macrumors 6502

    Joined:
    Apr 29, 2005
    #5
    Thanks for the suggestion of going to the Nike+ forum. I'll try that.

    Just goes to show you, though, I did 4.5 miles this afternoon and it didn't happen once. It's driving me crazy that I can't recreate the conditions that cause this.
     
  6. Robmcm macrumors newbie

    Joined:
    Nov 19, 2004
    #6
    It sounds like your pressing the menu button, as pause and voice control are both activated this way.

    Are you trying to get audio feedback like you used to in pressing and holding the center button (or headphone button) on the nano?

    I am not sure there is a way to do this one the 3gs
     
  7. fishballer macrumors member

    Joined:
    Sep 26, 2007
    #7
    holy crap, how did i miss this thread?

    i'm having the same problem too. I just run till the voice control pops up, then take the earphones off and keep running.

    I'm not pressing the menu button or any other buttons. it just comes up.

    was there any resolutions to this?
     
  8. arykmax macrumors regular

    Joined:
    Mar 2, 2008
    #8

    I'm pretty sure that you have to keep a consistant pace for calibration as well. If you are slowing down and speeding up or alternating between walking and running it probably will not calibrate. I know with my Nike+ wristband that I used before the iPhone, I had trouble calibrating at first due to walking around neighborhoods and waiting for traffic in some intersections. I decided to try walking a few laps around my block one day so I wouldn't have to change my pace and it calibrated that workout fine.
     
  9. Randman macrumors 65816

    Randman

    Joined:
    Jul 28, 2008
    Location:
    Jacksonville, Fla
    #9
    Check your iPod settings and click off "Shake to Shuffle".
     
  10. Andrew K. macrumors 65816

    Joined:
    Jul 9, 2008
    #10
    It'd be funny if that was the problem :D
     
  11. polonius macrumors newbie

    Joined:
    Jan 5, 2008
    #11
    I am having the same problem and I THINK I found the cause today -- I was running today with no problems until I used the remote to change the volume. Then it just started messing up. I think the problem is the iphone headphones with remote -- tomorrow I will try it with different headphones.
     
  12. jdavis at Abt macrumors newbie

    Joined:
    Jan 15, 2010
    Location:
    Evanston, IL
    #12
    Finally!

    What a pain this was. I too also worked with a previous device (nano and Nike+ gear). I got an iPhone 3gs and was pumped for a great 2010. My first like 8 runs were all TOTALLY off. I use the Marware pouch with my New Balance and found out that positioning is an issue. Nike Swoosh symbol to the sky...mistake one, it wasn't. So if you use the external pouch, beware...it also has to be snug, my was bouncin' around too much. Secondly is that the iPhone 3gs doesn't play nice with the calibration tool. I just did a twenty minute workout (on a treadmill) and at the end of it, hit calibrate and entered the amount of mileage the treadmill said. FINALLY! It's perfectly calibrated and off to the Nike+ races I go!
     

Share This Page