HD 5770 Problems

Discussion in 'Mac Pro' started by magicspot, May 26, 2015.

  1. magicspot macrumors newbie

    Joined:
    May 16, 2015
    #1
    Hey guys,

    Im having screen flickering and artifacting with my HD 5770. Its fairly frequent. It flickers off then back on or looks like a snowflake tv then it turns back on. Sometimes its one screen sometimes the other one. Usually not at the same time.

    As I type this one is well behaved the other is having issues.

    I run the HD 5770 and an HD 6870.

    I recently bought the 5'1 on craigslist. I upgraded the a hex core, ssd and 16gb. With just the HD 5770 in the machine I have no problems on single monitor DVI.

    I cant run 2x min dp without the screen flickering. Im running 2560 x 1600.

    So the card doesnt work even by itself.

    Outside of OS X for example In the bootloader or in the OS Setup I dont have the flickering issue.

    Its also not a cable issue, ive moved the cables to the 6870 and it seems fine.

    The 6870 works with no problems. I just need 4x mini dp.

    Ive tried PRAM and SMC. Neither worked.

    Im not trying to do anything fancy really just run basic tasks.

    Is the 5770 bad?

    Thanks.
     
  2. RoastingPig macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #2
    the 5770 is overheating, you need to clean and then reapply some thermal paste
     
  3. magicspot thread starter macrumors newbie

    Joined:
    May 16, 2015
    #3
    that seems totally reasonable. ill check it out.

    thank you.
     
  4. NOTNlCE macrumors 6502a

    NOTNlCE

    Joined:
    Oct 11, 2013
    Location:
    DMV Area
    #4
    +1 - whenever I purchase a used graphics card, this is always the first thing I do. Even if the card looks clean, the thermal paste is probably (at this point) 5ish years old, and could always benefit from a reapplication.

    Hope you have some success!

    -N
     

Share This Page