HD 7770 GPU and 10.11 DP

stmp

macrumors member
Original poster
Jul 17, 2012
51
0
Hello,

Anyone with an AMD HD 7770 was bummed when 10.10.3 was released since it dropped support for the HD 7770.

Curious if there's anyone on these boards running the 10.11 DP and has an HD 7770 for their cMP to test, especially since the new rMBPs R9 M370X is supposedly based on the HD 7770 from 2012.

Thanks in advance for any help here!
 

netkas

macrumors 65816
Oct 2, 2007
1,122
292
>How exactly it was bummed with 10.10.3 and what was the workaround?

Ah, I see, it's about these lines:
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>1</integer>

Will try to get it working in 10.10.3 as eGPU with mini2014 and if works, will try ElCap
 
Last edited:

netkas

macrumors 65816
Oct 2, 2007
1,122
292
Yes, ElCap still requires the patch for Info.plist of AMDRadeonX4000.kext as shown above.

After patch works fine, gui isn't using metal. But metal itself works.
 

stmp

macrumors member
Original poster
Jul 17, 2012
51
0
Thanks very much @netkas for the info!

@666sheep have you posted your efi.rom anywhere for sharing? I checked on netkas site but couldn't find it.