HD 7950 Port Mapping Question

Gazember

macrumors member
Original poster
Apr 5, 2017
51
16
My 5,1 MP has been working great. The 7950 has done an excellent job in FCPX, sticking with 1920x1080 resolution, using DVI or HDMI ports, what my trusty Viewsonic display supported.

Just recently I got the itch to move to 4K and ordered a new monitor. The Dell P2417Q has arrived and it is very nice with all the details I could never see before. While trying to achieve 4K @60Hz I discovered that neither of the display ports are actually working.

I got this HD 7950 off eBay a couple of years back, and it is just an average joe card flashed by some dude, not the official Sapphire one.

Is there a way to enable the display ports?

Also, would it make more sense to get a GTX Pascal now that drivers are available for OS X instead of messing with this older card.

Your advice would be appreciated.
 

Filin

macrumors regular
Mar 7, 2010
135
37
Ukraine
Seems you have non-reference design card flashed with original Sapphire Mac bios (but not sure). You should check card PCB layout.
 

h9826790

macrumors G5
Apr 3, 2014
12,776
5,585
Hong Kong
It's quite unusual that HDMI port work but both mDP don't. Did you check the cable? Or use the mDP with other display?

Anyway, you CANNOT boot a Mac EFI 7950 at 4k 60Hz. You have to do it either 4k 30Hz (force the monitor run at DP 1.1), or boot from the non Mac EFI ROM.
 

Gazember

macrumors member
Original poster
Apr 5, 2017
51
16
Unfortunately, this is the only monitor and cable I have to test with. I think I will wait for the Nvidia Volta and ADM Vega roll out and see where drivers and prices will land for a new card. I can live without boot screen, but not with graphics artifacts. Hopefully the last upgrade before the modular mac arrives.

Thanks