hd external problem in my imac

Discussion in 'iMac' started by ruisamuel123, May 25, 2015.

  1. ruisamuel123 macrumors newbie

    Joined:
    May 25, 2015
    #1
    HELLO i have a very strange problem in my hdata hd710... i use it like a external hd in my imac .... the think is ...last week the hd disapear ...don´t shows in the imac... just in disk utility but i can´t repair , i can´t mount,nothing ...i try in my macbook and is the same ... i try with disk warrior and the disk don´t apear ...i can´t see it there,,,,same with another similar programs like data rescue drive genius... i can´t see it there... and all the time i put the hd show me the error message...*the disk you inserted was not readable by this computer mac* now i don´t care about the hd i just want the files... but its so difficult cause i try so many thinks.... somebody can help me ? thanks
     
  2. koulmj macrumors 6502

    Joined:
    Mar 18, 2013
    #2
    That thing doesn't need it's own power supply does it? It just runs off the USB Ports?
     
  3. ruisamuel123 thread starter macrumors newbie

    Joined:
    May 25, 2015
    #3
    ...
    no is normal hd with usb ---

    ----------

    normal hd... but the think is i can´t mount it...:confused::confused:
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    I had a similar problem with a partition on a USB drive.
    One day it just wouldn't mount, no matter what I tried.

    Be aware that a data recovery app (such as DataRescue) may not be able to work UNLESS it can "see" the volume that it need to work on.

    What I did to get the drive "mountable" again:
    I actually RE-INITIALIZED the drive using Disk Utility -- BUT -- I DID NOT use the "secure erase" feature. DO NOT ZERO OUT THE DRIVE.

    Once the drive was re-initialized, it will show up again in the finder, but there will seem to be no files on it.
    However, when you do a quick re-initialize like this, it replaces the old (damaged) directory with a new (clean & empty) one.
    BUT -- it doesn't actually wipe clean the sectors out on the platters of the drive.

    What this means is that the actual data IS STILL ON THE DRIVE, even if the finder can't see it.

    Now, you can mount the drive in the finder, and use DataRescue to scavenge it and rebuild whatever files it finds.
    DR will "bypass" the "empty" disk directory, and "go right to the platters" to get the data back.

    You'll need ANOTHER drive to serve as the "scratch drive" to hold the recovered files.

    IMPORTANT:
    Be aware that DR may probably be able to get the old files back, BUT -- it will not be able to recover your old folder hierarchies and many file names. These were in the old, damaged directory that you replaced with a clean one, remember?

    If some of the files are music and photos, you may be able to dump the "unnamed" files into iTunes or iPhoto/Photos, and get file names back from the metadata that is in those files (this info may be preserved in the recovery process).

    Again --
    It seems like a drastic move to actually re-initialize the volume FIRST, and then use the data recovery software on it.
    But it worked for me, when nothing else would.

    Good luck!
     

Share This Page