HD & Memory Upgrade on my Mac Mini

Discussion in 'Mac mini' started by Sifter, May 12, 2009.

  1. Sifter macrumors newbie

    Joined:
    Apr 22, 2009
    #1
    So I successfully installed 4gig of memory as well as a 320gig HD. Before snapping the cover back on, I powered it up and made sure it still powered on. Looked good.

    So since it was a new HD, I then tried to put a dvd into the slot to load the OS. It wouldnt go. Its like something is blocking the opening.

    Have any of you ran into this? Im dreading taking this thing apart again.
     
  2. WhatLukeSaid macrumors newbie

    Joined:
    May 14, 2009
    #2
    you're probably not going to be able to fix this without opening it up again. You must have done something wrong. I would retrace my steps and double check everything is all good inside
     
  3. mooblie macrumors 6502

    mooblie

    Joined:
    Apr 23, 2009
    Location:
    The Highlands, Scotland
    #3
    Check that you have correctly re-seated (and fully screwed down) the black plastic internal frame. No internal wires trapped underneath the frame's four legs?

    Did your outer case snap back down all the way too? i.e. lower edges of case inline with base plate?

    Bluetooth and Airport antennae correctly repositioned? Slight, sprung travel in both antennae still possible, before you put the lid back on?

    Next time you have the lid off, insert/play/eject an optical disk, to confirm the optical drive itself is still working OK, before you put the lid back on.
     

Share This Page