HD not mounting, reading in diskutility, not erasing, not allowing eject etc. HELP!

Discussion in 'MacBook Pro' started by decackroyd, Jun 30, 2014.

  1. decackroyd macrumors newbie

    Joined:
    Jun 30, 2014
    #1
    I recently had an absolute nightmare where I was streaming over my network from my MBP 2012 to my ATV 3, simply playing videos from my itunes playlist.

    It then all of a sudden cut out, and I tried switching my mac back on but it kept dying after the boot logo. So I tried dumping PRAM, booting into recovery etc. It was then I notice that the HD (my 320gb Hitachi HDD which came with the mac originally) was displayed as connected but the one and only partition was displaying as unmounted, and would allow me to erase it, nor would it allow me to do anything. I attempted verifying (which came back as OK) and repair (which was the same) both of these I've repeated countless times.

    Also I tried disconnecting the HD and then putting it all back together but this made absolutely no difference.

    Either way I used this as an excuse to upgrade to an SSD, which is running fine and is now running mavericks etc.

    The problem I'm having is that I want to transfer some of my old data (i.e. films, and 4 years worth of art work) onto my SSD, erase the old HDD and use it as a portable backup as it's now in a caddy. However I'm unable to access any files, it's displaying exactly the same as when it was originally inside my mac.

    I've included a screen shot of the Disc Utility screen and a couple of the error messages I'm recieving.


    I'm beginning to give up hope that I'll be able to access my files which is a bit heartbreaking, most of it is backed up online in some way or another so it's not the end of the world, however I'd really like to use the HDD, it spins perfectly, no clicks, no issues at all, and as you can see from the images it's being read.

    Any help/ideas would be really appreciated.

    [​IMG]

    [​IMG]
     
  2. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
    #2
    First thing is first...if you're trying to recover data, why are you trying to erase the partition??? :eek:

    Do you have any diagnostic utilities on hand? DiskWarrior comes to mind and is an excellent piece of software.

    Another option - burn yourself a linux disk and check to see if you can't pull the data off that way. Ubuntu or Linux Mint are probably your best bet as they are relatively easy to use.

    Sometimes OS X and the recovery partition do not like to mount HDs or partitions that are having issues. Linux gets around this pretty well depending on the state the drive is in.
     
  3. decackroyd thread starter macrumors newbie

    Joined:
    Jun 30, 2014
    #3
    Hey thanks for the quick reply.

    I only tried erasing when I really have up hope (with only having 64gb of storage on the SSD I was going to make partitions for time machine, and use it as a storage device).

    I'll download disc warrior and try booting up Linux (though I don't have a partition for it, nor do I have access to a Linux computer)

    I'll get on disc warrior now though.
     
  4. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
    #4
    The linux disc is purely a live CD (meaning you can run it from the CD without installing it).

    DiskWarrior is a paid program so I'd try the linux method first if you can.

    Edit: not sure if DiskWarrior has a trial
     
  5. decackroyd thread starter macrumors newbie

    Joined:
    Jun 30, 2014
    #5
    Yeah I've just hit that stumble. I'll try finding a download for linux and make an attempt at using it now.

    ----------

    I'm currently attempting to use a freeware equivalent to disk warrior called Disk Drill, it's again recognised the drive, but is not able to rebuild it, I'm running through the long process of attempting all the recovery methods.
     
  6. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
    #6
    I can't really speak for Disk Drill as I've never used it but the HD issues come down to either A) bad hardware or B) corrupt software (e.g. filesystem).

    Did a quick read up on Disk Drill and the main differences I see are that Disk Drill is more along the lines of data recovery and DiskWarrior works to rebuild a corrupt filesystem (I might add that I've yet to have it not work, unless the drive was failing on a hardware level).

    If you do decide to try a linux CD just use the file browser, they're very similar to Finder, and see it your drive is browsable. More than likely it will be unless that drive is failing quite badly mechanically.
     
  7. decackroyd thread starter macrumors newbie

    Joined:
    Jun 30, 2014
    #7
    Right, I've managed to finally get the HDD to locate files using disk drill (which is now asking me to pay £50 to upgrade to the pro)

    I'm assuming my best course of action to format the drive so I can recylce it as a back up will be to do that through linux right?
     
  8. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
    #8
    You could format the drive via linux or even just browse your HD if it will mount in order to pull data.

    If you'd just rather format it, both Ubuntu and Linux Mint live CD's have a program called GParted that will allow you to wipe the drive if it's any good.

    **Before you do that though, I'd fire up Disks (in both of the above-mentioned distros) and see what it says about the SMART data on your HD.
     
  9. decackroyd thread starter macrumors newbie

    Joined:
    Jun 30, 2014
    #9
    I just tried force mounting in terminal (since I've got a big download on the Linux file, and it registered as 'permission denied'.

    I give up.
     
  10. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
  11. SantaRosa2.2 macrumors regular

    SantaRosa2.2

    Joined:
    Mar 7, 2012
    Location:
    Somewhere in Florida
    #11
    Are you using Utorrent as the admin? Sound like you have a corrupted drive from a torrent?
     

Share This Page