HD Showing as "Untitled" In Disk Utl

Discussion in 'macOS' started by Jesuslizardjr., Feb 8, 2017.

  1. Jesuslizardjr. macrumors newbie

    Joined:
    Jul 9, 2011
    #1
    I've been using my External HD fine today, suddenly it doesn't appear in finder at all (i've checked preferences, It's ticked to show External HDs), so i've opened Disk Utl to try and First Aid it to see what the issues are, but it's just listed as "Untitled" can't first aid it (Greyed Out), and when I try to mount it.. it just... does nothing, no error message or anything (See picture Below)

    As I say it was working fine earlier today, now it suddenly won't read, I haven't dropped it or anything in the interim. The light is on on the HD which means it's getting power, i've tried different cables, different USB slots, even a 2nd mac and nothing as of yet.

    Any ideas what the issue may be? Or any solution how I can gain access to the External HD, quickly remove all my files off there then bin it off for a new one?

    I recently whacked 16gb of RAM and a new battery in this Macbook, but that doesn't seem to have effected anything yet.

    Thanks.

    (Running El Capitan ver. 10.11.6, Early 2011 Macbook Pro)

    [​IMG]
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
  3. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #3
    Have you tried running disk first aid on the disk, rather than the partition labeled as "Untitled"?

    You can also attempt to fix the disk by calling "diskutil" in Terminal, or "fsck"? for instructions on how to use them, launch terminal, type in "man" then the command and it will give you explanations and syntax for how to execute the commands.. please be careful as the wrong command or "switch" for a command could result in total data loss.

    Additionally if the drive was formatted as an ExFat volume, you can try repairing the disk using a Windows installation if available and then utilizing "chkdsk " in command prompt.
     
  4. Jesuslizardjr. thread starter macrumors newbie

    Joined:
    Jul 9, 2011
    #4
    I have tried a restart (also tried an iMac)

    I have first aided the disk to no avail, I'd need to perform it on the actual expansion for this to do anything I'd imagine.
    I'm too nervous to even attempt using terminal for this just incase, the commands don't seem to have a first aid function, only repair disk, this I assume could result in data loss.

    It's unfortunately OS Journaled so won't work on a PC.

    Im running a data recovery program but I (thankfully) have the files backed up from November, what I need is some form of data recovery program that will restore the data from a certain date (November - Now) is there any software that might be able to show when the files were last edited once recovered?
     
  5. BLUEDOG314 macrumors regular

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #5
    I feel that disk utility has been getting worse since El Cap. Have you tried mounting the volume with terminal or anything like that yet?

    Also untitled is what the drive is named when it has been erased, are you sure you haven't erased it?

    Try opening terminal and typing "diskutil mount disk2s2" without the quotes, and hit enter. See if that lets you mount the volume.
     
  6. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #6
    Download SMART Utility and check if your drive is failing. Chances are it is.

    Also you need to check in the terminal diskutil list and see if the disk shows as two partitions disk1s1 and disk1s2. This will tell you if your partition map is damaged.

    If your drive is failing as I suspect, then be very careful about trying to mount the disk. I see people accidentally destroy their data all the time trying to save it. OS X is really hard on disks especially disks that are failing it hammers them to try to get a response–very bad for failing drives.

    If the disk passes SMART then I would invest in a copy of DiskWarrior as a start. You may also want to consider something like DataRescue depending on what you find with DiskWarrior.

    If the drive is failing, unless you know what you are doing it is almost always better to take it somewhere where they can recover the data safely. I am guessing you don't have access to things like write block docks and Atola Insights.
     

Share This Page