HD won't unmount

Discussion in 'iMac' started by nyroger, Jan 16, 2014.

  1. nyroger macrumors newbie

    Joined:
    Jan 7, 2014
    #1
    The title says it all. I have a HD that will not unmount from desktop regardless of what I try; control>eject, eject using keyboard, screaming, cursing, :D Anyone have an idea I can try?
     
  2. firedept, Jan 16, 2014
    Last edited: Jan 16, 2014

    firedept macrumors 603

    firedept

    Joined:
    Jul 8, 2011
    Location:
    Somewhere!
    #2
    This is an external drive we are talking about? Not your internal drive, I hope. Try dragging it towards your trash. Trash will turn into eject icon. May or may not work. Worth a shot since it looks like you haven't tried that yet.

    If it is your internal drive, then just open Finder>Preferences>General and then uncheck Hard disc as shown below. This will not eject it but will remove it from your desktop. You do not want to eject it.
     

    Attached Files:

  3. nyroger thread starter macrumors newbie

    Joined:
    Jan 7, 2014
    #3
    HD won't unmount

    Yes, Firedept, this is an external HD and I had tried to drag HD to trash with no result. After reading your response I tried it again with same result. After trying to drag to trash the second time for some unknown reason the HD ejected!!!

    The HD now appears to be responding well. If I have more problems I will repost. Thanks for your help.
     
  4. Twimfy macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #4
    It'll delay ejecting if the device is in use somehow. Many OS X programs still reside in memory/CPU processes even if they've been quit and they'll retain ownership of a file until they completely close (preview and Quicktime are the worst offenders).

    Usually an error will pop up saying a disk can't be ejected because it's in use but sometimes it'll just refuse to eject for a while. Not sure if it's a bug or not.
     

Share This Page