HDAPM question

Discussion in 'MacBook Pro' started by jomama7366, Nov 16, 2008.

  1. jomama7366 macrumors member

    Joined:
    Nov 1, 2008
    #1
    Okay, so I installed HDAPM to try to solve my noisy hard drive issue (on my Late 2008 MBP), but I've got a dumb question: how can I tell if it's running? I looked in Activity Monitor, but couldn't see it listed...
     
  2. sascha h-k macrumors 6502

    sascha h-k

    Joined:
    Apr 26, 2004
    Location:
    vienna / austria
    #2
    go to console and search for hdamp string ..

    you should see this:

    Setting APM level to 0xfe
    Success
     
  3. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #3
    If you can't get that "success" message to work, follow these instructions:

    1. First of all download ‘HDAPM’ from mckinlay.net.nz/hdapm

    2. If Safari doesn’t open it, click on the .DMG file yourself. You see 3 files: a readme, the hdapm.plist and the program itself.

    3. Now its time to reveal the hidden folders in Leopard. Go to the Terminal (you can search for it in spotlight; this is the searchbar with the magnifying glass at the top-right of you screen). Copy/paste the following line in the Terminal and press enter:

    defaults write com.apple.finder AppleShowAllFiles -boolean true;killall Finder

    Leave the Terminal open for now.

    4. Open the Finder, go to your Macintosh HD and then to the map /usr → /local → /bin. If there is no map /bin you will have to create it. Do this by Copying and pasting the following line in the Terminal and press enter:

    sudo mkdir /usr/local/bin

    Ignore the warning and give your admin password. The map /bin has now been created.

    5. Copy/past the program hdamp (not the .plist) to the /bin map.

    6. Go back to your HD and look for the map /library and then /launchDaemons. Put the hdapm.plist in here and confirm it again with your admin password.

    7. Restart your Mac. After reboot, open the console (use spotlight again) and search for the string hdapm (searchbar is again on the right).

    8. You will find:

    Setting APM level to 0xfe
    Success

    If this appears, you are done. Congratulations!

    But…. If you find:

    localhost com.apple.launchctl.System[2]: launchctl: Dubious ownership on file (skipping): /Library/LaunchDaemons/hdapm.plist*

    …you need to go on to point 9.

    9. To tackle this problem you have to download the program Lingon from lingon.sourceforge.net. Open it.

    10. You have to create a new .plist for hdapm. Click on New (top-left in the program) and check ‘User Daemons’ and then ‘create’. In the 1st field fill in:

    hdamp2

    the 2nd field:

    /usr/local/bin/hdapm disk0 max

    and following the 3, check:

    "Run it when it is loaded by the system (at startup or login)"

    You created hdamp2, as you can see on the left. Click on hdamp and disable it (uncheck the box with enabled) or delete it from /HD/library/LaunchDaemons. Reboot you Mac.

    11. If everything went right, your blip/pop sounds are gone. The only thing left to do is hide your folders again. Go to the terminal and copy/paste the following line and press enter:

    defaults write com.apple.finder AppleShowAllFiles -boolean false;killall Finder

    The End!
     
  4. jomama7366 thread starter macrumors member

    Joined:
    Nov 1, 2008
    #4
    Thanks for the replies. I actually did a lot more digging back when I posted this and finally figured it out.

    Cheers!
     
  5. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #5
    Jottle, for the amount of work required in Terminal anyways, you might as well skip showing hidden files in Finder and just copy the file directly.

    Your commands needed to be run would be as follows:
    sudo mkdir /usr/local/bin
    sudo cp [insert location of hdamp here] /usr/local/bin
    sudo cp [insert location of hdamp.plist here] /library/launchDaemons

    If you ever want to quickly tell Terminal the location of a file, just drag the file directly into Terminal. It will fill out the exact location.
    Make sure to add quotes around the file location if there are spaces in the address. The other option is to add a backslash ( \ ) in front of each space. Dragging a file into Terminal will automatically add backslashes.
     
  6. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #6
    Thanks for the clarification! Actually, I copied and pasted those directions from another forum. I have no clue how to work with terminal at the moment :)
     
  7. jomama7366 thread starter macrumors member

    Joined:
    Nov 1, 2008
    #7
    Anyone know if HDAPM still works in Snow Leopard?
     
  8. doug in albq Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #8
    still works in SL, including 10.6.1
     
  9. jomama7366 thread starter macrumors member

    Joined:
    Nov 1, 2008
  10. rvenners macrumors newbie

    Joined:
    Nov 24, 2009
    #10
    Found way to get hdamp to work in Snow Leopard

    I couldn't get hdamp to work using the "normal" instructions in Snow Leopard. Maybe because there didn't appear to be a local directory in Snow Leopard. Not sure...not a programmer. I found this link:
    http://mymacfixes.blogspot.com/2009/06/how-do-i-stop-clicking-noise-from-hard.html
    And now it is up and running and better yet, I haven't heard a click from my new Western Digital 500 GB drive.
     
  11. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #11
    Yeah, I own the same drive (Scorpio Blue 500 GB) and a couple of weeks ago I also followed the instructions on that site. Ever since, all the clicks/clunks have disappeared. It works like a charm! The only downside to it that I've noticed so far is that the HDD runs about 2-3 degrees Celsius hotter than otherwise, so now my avg. HDD temp is about 42 C. But I guess that's no biggie, right?
     
  12. maskedferret macrumors newbie

    Joined:
    Jul 22, 2008
    #12
    In 10.6.2, I cannot seem to find hdapm entries in the Console. I can run the app directly and see it report success in Terminal, but I do not know if the .plist file is actually working on startup.
     
  13. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #13
    Hey, hoping someone can help me out with this. So, I followed the install instructions from the link above. I dragged the HDAPM file to Applications/Utilities like it said, Then used Lingon to create a new Launchd configuration.

    When I run console to see if it's working I get:

    (com.andrew.launchd.hdapm[47]) posix_spawn("/Applications/Utilities/hdapm disk0 max", ...): No such file or directory

    I'm assuming I didn't enter the info correctly in Lingon when setting up the new Launchd config but I am new to this and am not sure where I am going wrong.

    Any help would be hugely appreciated.

    Thanks
     
  14. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #14
    - open Lingon
    - click the "+" icon and select Users Daemons and "Create"
    - under "Name" type com.yourusername.launchd.hdapm (note that you DON'T write yourusername as such, but your real user name with no spaces in between ;) )
    - under "What" type /Applications/Utilities/hdapm disk0 max
    - under "When" select "Run it when it is loaded by the system (at startup or login)."
    - then follow what the guy in that link said:

    3. Save and authenticate. This places the file com.yourusername.launchd.hdapm.plist in /Library/LaunchDaemons, from where it will run the specified Terminal command with root privileges at startup or login.

    4. Restart, then open Console. Search on "hdapm." You should see lines like this:

    6/30/2009 9:15:41 PM com.AaronShep.launchd.hdapm[42] disk0: WDC WD3200BJKT-00F4T0
    6/30/2009 9:15:41 PM com.AaronShep.launchd.hdapm[42] Setting APM level to 0xfe:
    6/30/2009 9:15:41 PM com.AaronShep.launchd.hdapm[42] Success

    That confirms it! Your clicks will be gone and your drive will wear normally. Enjoy your quiet computer!
     
  15. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
  16. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #16
    Thanks for your help Jon08.

    Ok, still getting the same error. Here is exactly what I did:

    1. I clicked on the "+" and selected "User Daemons"
    2. Now... for "Name" I am assuming that is the first field that says "Label". My Account name is "Andrew Turner" so I entered "com.andrewturner.launchd.hdapm".
    3. I am assuming that "What" is the next field called "Program Arguments". I clicked the "+" and in the top field I entered "/Applications/Utilities/hdapm disk0 max".
    4. I clicked the box that says "RunAtLoad".
    5. Saved and restarted... same error.

    Again, thank you for your help on this. I got a new WD Scorpio Blue 500 and am having intermittent stutters every 30 seconds or so and really want to get rid of it so I can enjoy this drive. I am hoping this helps.
     
  17. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #17
    You're apparently dealing with a totally different configuration than you were supposed to. There is no "Program Arguments" or "Label" in which I described to you.

    Now first off, trash any hdapm related files you've installed on your computer, so that the only hdapm related file will be the hdapm.dmg file itself. I am not sure why you clicked the "+" button more than once, either. You're only supposed to click it in the very beginning when you're making a new launchd configuration. And when you click on the "+", a window will open saying "Where should the launchd configuration file be placed?" - and you select the third option, which is "Users Daemons," then click the "Create" button.

    Now, go back to my post and do exactly as I wrote. In the "Name" section, enter com.andrewturner.launchd.hdapm as you wrote. Then when you get to the point where it says "under "When" select "Run it when it is loaded by the system (at startup or login)" check that option, then click the "Save" button next to the "+" button above.

    Now restart your computer and then run Console and look for hdapm logs. If the log says what I wrote above, then you're good.
     
  18. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #18
    So, just to be clear, I should trash the hdapm file that I dragged from the mounted hdapm.dmg folder into Applications/Utilities?

    Again Jon... your are a saint, thank you for the help.
     
  19. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #19
    See, once I click "Create" I get a window that has 5 buttons across the top "Basic, Miscellaneous,Paths, Limits, Sockets, Experts". Under those buttons I have fields called "Label, Program Arguments, Program and Description", and three checkboxes that say "Disabled, RunAtLoad, OnDemand". I don't see any fields for "Name, When etc."

    I am using Lingon 1.2 if that helps.
     
  20. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #20
    Um, 1.2 seems really old to me. You need to get v. 2.1.1, which you can download here: http://www.macupdate.com/info.php/id/19879/lingon
     
  21. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #21
    Ok, I see I was using an older version of Lingon... sorry, got it now. Got the success message so hopefully this addresses my issue. Thanks again.
     
  22. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #22
    Oh well, this didn't fix the issue for me... thanks again. Not sure what else to do with this drive but the stalling is pissing me off. Guess I will return it.
     
  23. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #23
    That's odd. You said you got the success msg and you're still experiencing clicking?
     
  24. ethandt macrumors member

    Joined:
    Jul 26, 2009
    #24
    Long story short, ever since installing this drive I had had a problem where everything just stalls for a split second every 30 seconds or so. Through all the searching on this forum I found two things that could be causing this, either the firmware 1.7 problem or this where the heads are parking. This was one fix I wanted to try, another member here described the same symptoms as mine so I wanted to give this a shot. The other potential fix was the EFI Firmware issue and downgrading to 1.6. But everything I have read in that thread states that that particular issue is only relevant to MBPs from mid 2009 on (with the SD Card Slot), mine is an early 2009 with the express card slot.
     
  25. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #25
    Sorry to hear about that man. I was able to fix my Scorpio Blue 500 GB with hdapm. Good luck!
     

Share This Page