HDD partitions messed up iMac late-2009 - 4TB HDD

Discussion in 'iMac' started by brenco, Jul 3, 2016.

  1. brenco macrumors newbie

    brenco

    Joined:
    Jul 3, 2016
    #1
    Hi people,

    I've looked all over the web for an answer, and I came close but I'm not certain how to proceed. This is what happened:

    On Yosemite - I wanted to install Windows 7 on my late-2009 iMac 27" with a 4TB HDD. In Bootcamp I wanted to make a partition - failed, it refused to do so. I went to disc utilities. Made a new partition (1,5TB) and formatted it Windows NT. After doing so my HDD was stuck with 2 partitions - 2,5 journaled HFS+ and 1,5TB unused partition!

    I couldn't adjust it, remove it or reformat it, just dead space. I read somewhere it could be due to Yosemite having a bug in it. I upgraded to El Capitan (don't like the OS personally, but always better than a bricked hdd). In El Capitan it says:

    "Change failed..."
    details says
    "Execute change 1 of 2...
    Name invalid.
    Change failed..."
    (I translated from Dutch)

    -Of course I gave it a proper name like "abcd", so that can't be the problem.


    Here my diskutil list.

    MacBook-van-Rick:~ Rick$ diskutil list
    /dev/disk0 (internal, physical):

    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *4.0 TB disk0
    1: EFI EFI 209.7 MB disk0s1
    2: Apple_HFS RickHD 2.5 TB disk0s2
    3: Apple_Boot Recovery HD 650.0 MB disk0s3
    4: Apple_CoreStorage RBWindows 1.5 TB disk0s4
    5: Apple_Boot Boot OS X 134.2 MB disk0s5


    FirstAid on the HDD doesn't report any anomaly and says the disk is fine.
    Removing the partition doens't work "... Cocoa error -1)."
    fsck_hfs -> volume appears to be OK




    If this helps: testdisk output:

    Disk /dev/disk0 - 4000 GB / 3726 GiB - 7814037168 sectors (RO)

    Current partition structure:

    Partition Start End Size in sectors

    1 P EFI System 40 409639 409600 [EFI System Partition]
    2 P Mac HFS 409640 4882817943 4882408304 [Naamloos 1]
    3 P Mac Boot 4882817944 4884087479 1269536 [Recovery HD]
    4 P Unknown 4884349624 7813774983 2929425360 [RBWindows]
    5 P Mac Boot 7813774984 7814037127 262144 [Booter]




    And on analysis:
    Disk /dev/disk0 - 4000 GB / 3726 GiB - 7814037168 sectors (RO)
    Analyse sector 4893802496/3519069871: 01%

    check_FAT: Unusual media descriptor (0xf0!=0xf8)
    Warning: number of heads/cylinder mismatches 16 (FAT) != 1 (HD)
    Warning: number of sectors per track mismatches 32 (FAT) != 1 (HD)

    EFI System 40 409639 409600 [EFI]
    Mac HFS 409640 4882817943 4882408304
    Mac HFS 4882817944 4884087479 1269536
    Mac HFS 4884349620 4885619155 1269536



    What should I do?

    Thanks for your help!

    Rick
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Confirm RBWindows is the partition you want to ditch? If so... do this.

    Reboot and hold command-r to boot to recovery. In the Utilities menu launch Terminal then enter the command below to wipe the RBWindows partition. Somehow you managed to make that partition a core storage volume and that is why you are having trouble getting rid of it.

    Code:
    diskutil cs delete "RBWindows"
    Now quit Terminal and launch Disk Utility and run a First Aid. Then try to resize the RickHD volume to take over the now unused 1.5TB of space.

    Once that is done reboot and you should be all set.
     
  3. brenco thread starter macrumors newbie

    brenco

    Joined:
    Jul 3, 2016
    #3
    Dude, you're gold. That totallly worked! First it only worked half (erasing the partition, but couldn't join). Then after a reboot, tried it again and totally worked. Thanks so much!
     

Share This Page