HDD Problems (Possibly)

Discussion in 'MacBook Pro' started by Rawrzilla, Feb 4, 2013.

  1. Rawrzilla macrumors newbie

    Oct 14, 2012
    First let me start off by saying I'm not a computer tech and what I know is generally from personal experience or reading around (I do alot of that) now onto the problem. It seems I may be having a HDD problem as my macbook pro isn't recognizing the HDD after a force restart (laptop froze) Ive had this issue before and took it to the shop before and told it was a hardware failure and was told to reformat this should fix it long behold for that time it did, this time it wishes to be stubborn just my luck right? Now enough rambling on from me and let me actually explain what brought me to this problem.

    I opened a program (cleanmymac) the computer instantly became unresponsive for a long period of time, this is the first time its happen so I was baffled and left with no choice but to restart it forcefully. When the laptop launched back up it didn't go to the normal screen It had a gray background with a blinking folder with a question mark on it, as I said before Ive seen this before so my instant reaction was to get into the utility disk to verify and repair the disk It wouldn't even make it through the verifying completely as a red line popped up saying "problems were found with the partition map which might prevent booting" so after Ive been given that error I went to repair the disk but it wouldn't let me either due to another error that I can't exactly recall. So I was left no choice again but to reformat heres where the real problem begins, it goes through the process of reformatting but stops due to a error "posix reports the operation couldn’t be completed. no such file or directory" no idea what that meant.

    With all that being said I've tried another idea which is forcing it to unmount by doing "diskutil unmount force /dev/disk0" but I get something telling me diskX was already unmounted or it has a partitioning scheme so use "diskutil unmountDisk". I do what it says and that pops up with this "/unmount of disk0 failed: at least one volume could not be unmounted" I have no idea what that meant but seeing as the above message said it was already unmounted I tried zeroing out the disk and it gives me "Error with zero disk erase: Couldn't open disk (-69879)". I've tried erasing the HDD completely before doing all the things I've mentioned above which didn't properly erase popped with a message rather the error "Unable to write to the last block of the device" can't remember if it had the last part on it (of the device) but it for sure had unable to write.... part. I also repeated the above steps by forcing it to unmount and zero the disk It gave me the same thing but a different message "Error: -68988: Couldn't unmount disk".

    So in conclusion despite all the error's Ive got which I must admit I get a lot, with all the reading Ive done I'm simply lost for words and have ran out of ideas to bring the machine back to life. I hopefully think someone in here and help me with this problem or has had it before and can pinpoint me to fix or tell me if my HDD is completely dead (I don't think it is, system still boots up).

Share This Page