HDMI audio issues with 2010 Mac Mini

Discussion in 'Mac mini' started by bensonhedges, Jan 8, 2012.

  1. bensonhedges macrumors newbie

    Joined:
    Dec 8, 2008
    #1
    Hi guys,

    Since upgrading my Mac Mini to Lion a few months ago, I've been having a seriously annoying problem with HDMI audio output. When I play media files with stereo audio tracks (e.g. music, some TV show rips), it only plays back through the front two speakers of my 5.1 surround setup, bypassing the sub completely. As you can imagine, due to the lack of bass, this sounds tinny and horrible. Previously, when I was using Snow Leopard, it outputted stereo tracks through the whole 5.1 setup, which sounded way better. This problem occurs regardless of what program I use for playback.

    Does anyone have any ideas on how to force my Mac to output stereo through all 5.1 channels? Any help would be greatly appreciated :)
     
  2. bensonhedges thread starter macrumors newbie

    Joined:
    Dec 8, 2008
    #2
    Sorry, I should have included some specifics in my OP.

    It's a 2010 Mac Mini (Server model, 2.66ghz C2D), plugged into a Sony HDMI receiver. It's running 10.7.2.

    The amp has a function whereby it will play stereo audio out through all 5.1 channels, but this doesn't work in this case. I've tried hooking up other stereo kit to the amp, and it successfully outputs across all 5.1 channels, so I'm convinced that it's the Mac Mini at fault as opposed to the amp (also, it used to work just fine using Snow Leopard).

    My theory is that the Mac is attempting to output the stereo track as 5.1, and is telling the amp that it's a 5.1 track (and, in doing so, disabling the amp's function to output a stereo source across 5.1), but is only sending to two speakers.
     

Share This Page