HDMI Audio out not displaying anymore

medz52

macrumors newbie
Original poster
Feb 8, 2010
21
0
College Station, TX
I have the OWC adapter, works all the time, even last night. But now for some reason I can't seem to find the hdmi out selection in the sound part of preferences using 1.4 hdmi cords/ports.

Any thoughts?
 

diablo2112

macrumors 6502
Apr 16, 2010
350
7
The HDMI audio out only appears when your HDMI cable is connected to a display. If disconnected, it won't appear in the sound preferences output panel.
 

medz52

macrumors newbie
Original poster
Feb 8, 2010
21
0
College Station, TX
I know that it needs to be connected which it is, to my reciever instead of display. Shouldn't the receiver (which is hdmi 1.4) be sending a signal to my macbook pro that it can receive audio in? Its an Onkyo s3300, and the cable box i have already sends audio over hdmi perfectly, it just won't show up in my audio outputs in the system preferences>Sound
 

diablo2112

macrumors 6502
Apr 16, 2010
350
7
I know that it needs to be connected which it is, to my reciever instead of display. Shouldn't the receiver (which is hdmi 1.4) be sending a signal to my macbook pro that it can receive audio in? Its an Onkyo s3300, and the cable box i have already sends audio over hdmi perfectly, it just won't show up in my audio outputs in the system preferences>Sound
I've not tried this configuration. Try hooking up directly to your HDMI display, and see if that works. If so, you've found the problem. The MDP-HDMI connection is a bit tricky, I wouldn't assume a connection through an HDMI-switching receiver would be sufficient for the MDP port to recognize the audio or video connection.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.