Resolved HDMI CEC not working perfectly anymore partly

Carlanga

macrumors 604
Original poster
Nov 5, 2009
7,011
1,291
So W the atv4 I used to be able to turn on the tv and I out to the atv w any button press from the Siri Remote, but now the Siri Remote doesn't do that. But it does control the volume. AirPlay doesn't turn the input neither.
It used to work fine but I changed it to a much longer hdmi cable and idk of that is the cause or an update to the atv4 has caused it. All settings that I see for it are ON. I just want to know so as to know if I need to change th cable or what. TIA
 

benjitek

macrumors 6502a
Sep 23, 2012
865
434
Mine's working fine. It's also working with a new 2016 Roku Streaming Stick. If I press a button on the Siri Remote, the input switches -- same with the Roku remote.
 
  • Like
Reactions: Carlanga

Carlanga

macrumors 604
Original poster
Nov 5, 2009
7,011
1,291
Mine's working fine. It's also working with a new 2016 Roku Streaming Stick. If I press a button on the Siri Remote, the input switches -- same with the Roku remote.
Must be the long hdmi cable then. Thanks for the reply!
 

Carlanga

macrumors 604
Original poster
Nov 5, 2009
7,011
1,291
Figured it out. It wasn't the new cable for the atv, but the new cable I used for the cable box that didn't let hdmi cec to turn on or change inputs. stupid cable boxes...
 
  • Like
Reactions: satcomer

Hermes Monster

macrumors 65816
May 4, 2010
1,145
304
UK
Glad you figured it out, mine has become extremely annoying lately, messing with what my TV thinks is each HDMI input, incorrectly labeling them and switching inputs when I press the remote for my Sky box. I really should just turn CEC off
 
  • Like
Reactions: Carlanga