HDMI Connector

rchetek

macrumors newbie
Original poster
Jul 24, 2011
3
0
I have two HDMI adaptors. I bought the first and took it to my condo. It worked great. It worked with my iPhone 4 and Ipad2. I bought another for home and it worked great as well. Now, about 4 weeks later, I was at my sisters house, who also has one, and I pluged into it and I got a message on my phone "This accessory is not supported by Iphone" I came home and tried mine, and same message. I pluged in the Ipad2 and it works great, so it's not the adaptor. Any suggestions as to the problem or a solution?
 

MagicalWhiffle

macrumors newbie
Jul 10, 2011
7
0
I expect the most likely scenario is that the iPhone's docking/charging port is at fault. Sometimes lint and corrosion can affect a good connection. You can try cleaning the port with a tooth brush and/or an alcohol pledget. If this turns out to be the case, in the future you can prevent this by using an iPhone port cover.

If after cleaning it you still get this message, I would ask whether or not you get the same message when connecting the iPhone to your computer.
 
Comment

rchetek

macrumors newbie
Original poster
Jul 24, 2011
3
0
Good idea MagicalWhiffle, I did what you said, and it started working, but only spotted. I have to push to adptor very hard to make it contact and the slightest movement causes it to disconnect. I think it just needs more cleaning.

I have not had any problems charging or connecting to my computer.
 
Comment

Similar threads

Replies
0
Views
182
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.