HDMI No Sound From Internet

Discussion in 'Mac Accessories' started by aCondor, Nov 11, 2012.

  1. aCondor macrumors 6502

    Joined:
    Oct 20, 2010
    Location:
    United States
    #1
    Hi everyone. Quick question from me. Something's been bothering me for a while and I haven't been able to figure it out.

    I have a Mini Display Port to HDMI cable that I use to connect my 2011 Macbook Pro to a Panasonic HDTV. Mostly for movies. At first, everything works fine. Video is great. Audio is great.

    However, audio doesn't work when I use the internet. I've tried YouTube via Firefox, Chrome and Safari. Couldn't get any sound through internet. VLC and similar local players work fine.

    Has anyone had similar problems?
     
  2. aCondor thread starter macrumors 6502

    Joined:
    Oct 20, 2010
    Location:
    United States
    #2
    Almost 500 views and no replies. Must be a rare problem. I'll continue fiddling around and update when or if I solve this problem.
     
  3. AppleMacFinder macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #3
    Are you using a Flash player, or HTML5 player?
     
  4. aCondor, Nov 12, 2012
    Last edited: Nov 12, 2012

    aCondor thread starter macrumors 6502

    Joined:
    Oct 20, 2010
    Location:
    United States
    #4
    Flash player. I haven't tested HTML5 yet. Will do.

    EDIT:
    Tested HTML5 and audio does work! Great!

    Now the question is how to get audio to work through Flash... Any ideas?
     
  5. AppleMacFinder macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #5
    Ideas are rather simple to come up with:
    1) Update Flash player if it is outdated
    2) Reinstall Flash player if it is up-to-date
    3) Remove Flash player completely and use HTML5 only

    Don't forget that Google Chrome uses its own built-in Flash player, so you need to reinstall it as well.

    The third idea is my favorite: when I need Flash (on rare occasions), I use Chrome, because it has built-in Flash.
    I don't have a standalone Flash installed, because it makes my browsing experience worse.
     

Share This Page