HDMI Port on MacbookPro 2015 13"

Discussion in 'MacBook Pro' started by MyNamesNotBob, Nov 5, 2017.

  1. MyNamesNotBob, Nov 5, 2017
    Last edited: Nov 5, 2017

    MyNamesNotBob macrumors newbie

    Joined:
    Jun 21, 2010
    #1
    I've got MBP 13 late 2015 - I don't use it much as it's my backup. Everything works fine, except the HDMI port. Going through DisplayPort its' fine, use adaptors to HDMI, VGA whatever - all good.

    But using the native HDMI port nothing - it detects no screen, screen does not detect it, it just does nothing. Any ideas what it could be?

    I have done all the PRAM and SMC reset, 4 monitors/tv's tried, different cables. Safe mode too

    As said it works fine through DisplayPort, but native HDMI seems to be dead. Am I missing something?

    I have tries deleting various preference files, again nothing.

    Only thing left is to flatten the machine and start again, but I can't really be bothered to do that.

    Any ideas?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    What display are you using it with?
    Have you tried a different HDMI connecting cable?
     
  3. MyNamesNotBob thread starter macrumors newbie

    Joined:
    Jun 21, 2010
    #3
    Tried on Samsung 7000 series 55" TV, Samsung 42" 6000 series, LG 55" TV, Samsung U28E590DS 4K Monitor, Asus PA329Q - all work with the 2015 over DisplayPort into an an adaptor via HDMI. All work with my 2017 MBP using same cables.

    Also various projectors and TV's on client sites.

    tried 5 different HDMI cables - all through the above TV's

    The only thing that doesn't work is the native HDMI port
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    Are you near a brick-n-mortar Apple Store?
    I'd take it to the genius bar, and ask them to check the function of the HDMI port...
     

Share This Page

3 November 5, 2017