HDMI problem after El Capitan update

Discussion in 'OS X El Capitan (10.11)' started by appeardk, Oct 3, 2015.

  1. appeardk macrumors newbie

    Joined:
    Aug 28, 2009
    #1
    Hi

    I have been using two Mac Mini's as mediacenters around my house.

    One is an older Mid 2010 and the other a Late 2014 model.

    Both are connected via HDMI to a TV, and usually I control them by connecting via remote desktop. Sometimes via remote (iRed IR or Apple Remote).

    After updating them both to El Capitan they both have acquired a very annoying "energy saving" behaviour which makes them almost useless :-/

    The minute I disconnect from Remote Desktop the picture on my TV instantly goes black, but the audio resumes and the mini is not in sleep mode. If I reconnect the picture appears instantly.

    If I reboot the mini it will work as before (I can put on a movie, close Remote Desktop and the movie will play on the TV) for a while, but after a couple of hours the old behaviour returns.

    I have tried:
    - Putting all energy saving settings to "Never" / Off
    - Re-detecting my display by holding "alt" in the Display settings and then pressing Detect display
    - Shouting, lots of shouting

    Has anyone else experienced this problem yet?

    Any suggestions on how to fix this problem would be most welcome. I just watched a concert-video and I had to keep my macbook connected via remote desktop for the entire duration - after 1 hour the macbook was up at it's melting point :)

    THANKS
     
  2. appeardk thread starter macrumors newbie

    Joined:
    Aug 28, 2009
    #2
    Can anyone using a similar setup (mini as mediaserver) confirm the problem?
     
  3. shiftyskies macrumors newbie

    shiftyskies

    Joined:
    Oct 2, 2015
    #3
    I have Apple TV connected to a TV via an HDMI cable. Since the El Capitan upgrade, I have sound coming through to the TV but like yourself I have no display either. I done all the usual checks, unplugged equipment, restarted it, checked for updated software. It still doesn't work.

    I was able to get round the issue by installing some third party software called Airparrot and I got my display back. As a test, I then uninstalled it and the display stopped working again. Whatever the issue, it does appear to be software related and directly connected to the El Capitan upgrade.
     
  4. appeardk thread starter macrumors newbie

    Joined:
    Aug 28, 2009
    #4
    Hi Shiftyskies

    Thanks for giving your input here. I hope you find a solution as well.

    I investigated some more and found out that the singal would be fine right after a reboot, but once the mini had entered sleep state and then was woken up the problem would come back, and the only way of keeping the image feed on my TV (via HDMI) was to keep the remote desktop connection open.

    A "fix" for my part is to disable all sleep-features but thats far from ideal.
     
  5. appeardk thread starter macrumors newbie

    Joined:
    Aug 28, 2009
  6. George Dawes macrumors 6502

    George Dawes

    Joined:
    Jul 17, 2014
    Location:
    Woof bark donkey
    #6
    Any update on this as my mac mini 2011 model is essentially bricked due to this weird bug
     
  7. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #7
    No time to track the threads down, but sounds like this is normal behaviour. Apple got aggressive re: energy saving as part of being compliant with EU energy regulations.

    Not specific to this thread, but others have posted issues where Macs go into pseudo-sleep-like modes with displays, drives, etc. and "breaks" other uses for machines.
     
  8. shiftyskies macrumors newbie

    shiftyskies

    Joined:
    Oct 2, 2015
    #8
    I don't know if this will resolve your problem assuming that it's still an ongoing issue for you, but it just might. I upgraded to the latest version of OSX when it came out a couple of days ago (10.11.5). Unfortunately it didn't still didn't work. I then did a backup up my data in Time Machine, created an el Capitan USB boot disk using Disk Maker, downloaded el Capitan again from the App Store and then did a fresh install. Once I rebooted my issue was resolved.

    Unfortunately, once I restored my Applications from Time Machine I lost Airplay functionality again. Turns out that an old application that I had uninstalled (Airparrot) months ago was causing the problem..

    To resolve that issue I had to delete associated entries:

    APexFramebuffer located at: System/Library/Extensions

    AirParrotDriver located at: System/Library/Extensions AND Library/Extensions

    I then emptied the trash and restarted my computer and it worked again.

    I realise that your issue is somewhat different to mine, but with the latest update 10.11.5 it could be that a clean install might resolve your issue. Anyway, hope you get your issue fixed if it isn't already.

    I read somewhere that other third party apps are the cause of similar issues such as iDisplay, Splash screening Air Display.
     
  9. George Dawes macrumors 6502

    George Dawes

    Joined:
    Jul 17, 2014
    Location:
    Woof bark donkey
    #9
    I seem to have got round this by setting the energy saver panel to display sleep after 3 hours

    Then wake up the mac display connection on mouse click , unlike when it' set to 'never' and never wakes up... Weird eh ?

    Steve Jobs always said hdmi was a bag of hurt - looks like he was right -again
     

Share This Page