HDTV connection:Mini Display port or Mini Dvi?

Discussion in 'Mac mini' started by atcskyfox, Apr 6, 2009.

  1. atcskyfox macrumors newbie

    Jan 28, 2006
    I need to connect my 09' Mac Mini to my Yamaha RX-V2700 receiver which outputs to my Sony XBR HDTV. I know the mini has both mini-dvi to dvi and mini-dp to dvi or hdmi available via adapters. I was thinking to go with option 1 however I was wondering what is your opinions? Is mini-display port better over mini-dvi or are they the same? Audio will be carried over optical toslink.

    Option 1:
    Using mini-dvi adapter to dvi: Connect Dvi-Hdmi cable to receiver and output audio with toslink adapter.

    Option 2:
    Using mini-dp adapter to dvi or hdmi: Connect Dvi-Hdmi cable to receiver and output audio with toslink adapter.
  2. jwilcox09 macrumors member


    Oct 22, 2007
    I just got my mini the other day and have mine hooked up to my 42" Panasonic via the Mini-DP to DVI to HDMI and I notice that there is no way for it to fill the screen. Either there is a 1.5" border of black with overscan on or with overscan off the menubar and half the dock and about 1" on both sides are outside the viewable area. Tried all different Res. Haven't done the Mini-DVI since I didn't want to buy two adapters, but thats my experience with the Mini-DP.
  3. robotartfashion macrumors 6502

    Jan 1, 2009
    Phoenix, AZ
    i just ordered both a mini-dvi to hdmi and a mini-dp to hdmi from monoprice to try them out

    i'm also hoping that the mac hardware is audio capable for the mini-dp that so that in the future apple *may* enable audio passthrough in the software

    we'll see what happens

    as far as the other poster, if you do a internet search you'll see that this is a problem with some HDTV's in conjunction with osx, you can look into switchresx to see if you can get it working, good luck :)
  4. brand macrumors 601


    Oct 3, 2006
    I can verify that as of right now Apple does not use the Mini DisplayPort to pass audio. I have both the Mini DP to HDMI adapter from MonoPrice and it only passes video. If you want audio you will need to run another cable. Hopefully when SnowLeopard is released Apple will decide to conform to the standard and enable the passing of audio through Mini DisplayPort
  5. federikk macrumors newbie

    Apr 6, 2009
    Quite a common iussue, try this

    i'm supposing you've windows already installed, and also that there's no easier solution like a on-tv overscan control:

    let's start from microsoft os:
    download moninfo, and take from there all the info on timings (a string of number like 1280 1360 1450...and so on)of your TV at the resolution you are using (hd/fullhd);
    put them into dtd calculator, then edit the resolution, click on "ruler" and accomodate the box to your TV(look at the red edges!) and close the box with the apply button.now go back to main dtd screen.
    Dtd calculator is only for intel graphic, so you've got to basically take the resulting timing to use it in other programs(i suggest you to print the page with timings!):
    first (if you want to accomodate also windows) create a custom resolution with nvidia driver (pay attention the timings are not in the same order on this interface!!!(you can obtain the order by looking at the data in the original configuration, the right numbers must match)), reboot if required and use the new resolution: image should fit perfectly your screen estate!

    finally, reboot in osx, download and install switchresx, and create again a custom resolution with the last data from dtd calc(again pay attention the timings are not in the same order on also this interface!!! ) with the dtd "hacked" timings. Reboot if required, and use the new resolution.

    the image will correctly fit your TV
  6. jwilcox09 macrumors member


    Oct 22, 2007
    Thanks I'll have to check out that program and see if that will do it. Also let me know which way you prefer when you get the adapters.
  7. AVR2 macrumors 6502

    Jan 16, 2006
    I've got an '09 mini hooked up to a 42" Panasonic plasma (mini-DVI to DVI to HDMI), and it's filling the screen like a champ :cool:

    I'll bet your problem is this: both the computer *and* the TV have their own separate overscan settings. The trick is simply to have overscan in the mini switched ON, and overscan in the Panasonic switched OFF (it should be in Menu>Setup>Picture Overscan).

    That should fix it. It did for me. No need to screw around with SwitchResX :)

    BTW, to answer the OP - there's no difference in quality whether you go DisplayPort>HDMI or DVI>HDMI.

Share This Page