Headless Mac Mini

Discussion in 'Mac mini' started by mattonthemoon, Aug 9, 2012.

  1. mattonthemoon macrumors regular

    mattonthemoon

    Joined:
    Feb 25, 2007
    Location:
    Toronto, ON
    #1
    Hello,

    I have a 2011 Mac Mini, using it as a server in my home, running 10.8 server.

    However, when it's headless (no display attached), i am not able to remote in with either the Apple Remote Desktop app, or the screen sharing.app.

    It just sits at "connecting...".

    I can however connect remotely with logmein, but i prefer to use Apple Remote Desktop or screen sharing.app as i did with my 2006 iMac.

    Any insights on what i am doing wrong?

    Thanks.
     
  2. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #2
    I use my 2011 Mac Mini as an itunes server anymore. I always access screen sharing by going to finder, selecting my Mac Mini from the network devices, then in the upper right hand corner is a "screen sharing" button. Then I can just log into my Mini using one of my admin accounts with no issue. I used to use the "connect to server" in the drop down menus, but find this much easier especially when accessing Mac to Mac (Mac to PC still requires the old route).
     
  3. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #3
    You can also create a desktop alias for connecting straight to the server. Create a weblink to vlc://ip_address and that will let you have the desktop shortcut.
     
  4. marzer macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #4
    On the mini, disable "Screen Sharing" and enable "Remote Managment" and then set the remote options. This will avoid the dialog on the mini to permit the incoming screen sharing connection.
     
  5. Panch0 macrumors 6502a

    Joined:
    Feb 23, 2010
    Location:
    Virginia
    #5
    That sounds like a firewall problem, or that the server is not correctly set up to allow screen sharing. I believe that Logmein runs across either port 80 or 443, through logmein's servers on the internet, bypassing settings on your local network. I would probably start by connecting to the server and turning Screen Sharing off then back on. Turning on a service on a Mac will usually take care of any security setting that it requires, so maybe re-enabling it will clear things up.
     

Share This Page