Headphone adapter clicking

Discussion in 'iPhone Accessories' started by MattXDA, Sep 18, 2016.

  1. MattXDA macrumors 6502

    MattXDA

    Joined:
    Aug 18, 2014
    Location:
    UK
    #1
    The headphone adapter for the iPhone 7 is making a clicking noise every 2 seconds and cutting out audio during the click. I've tried unplugging everything etc and it is still occurring. Anyone else had this?
     
  2. gkingha, Sep 18, 2016
    Last edited: Sep 18, 2016

    gkingha macrumors member

    gkingha

    Joined:
    May 2, 2016
    Location:
    Canada
    #2
    I had this today as well. I switched headphones and it went away after a few times re-inserting the adapter into the lightning port a few times. Not sure if it was the headphones or the Iphone, so i'll have to wait and see. Will see if it happens again, if so i'll get it swapped out.

    Update:

    I just tried 5 different sets of headphones and it only happened with 1 set of headphones (and there old), so perhaps it's the headphones themselves. Again i'll have to monitor it and see how it goes.
     
  3. blotto80 macrumors member

    Joined:
    Jan 26, 2012
    Location:
    Houston, TX
    #3
    I just experienced this as well, but it only starts to click after i hit pause not during playback. And once i hit pause and it starts to click i cant use the inline headphone controls anymore, i have to hit play on my phone or unplug and plug again into my phone to regain the heaphone inline controls. I'm using the Bose mei2.
     
  4. AndrewInFlorida macrumors newbie

    AndrewInFlorida

    Joined:
    Nov 16, 2017
    #4
    I found the solution and then searched for some threads to post it. If you are using a wired headset with mic (and 4-segment jack), click the "Volume Up" and "Volume down" on the wired headset and it stops.

    Why? Lord only knows. When you use the volume controls on a wired set, it seems to make a light pop with each key press. Somehow, pressing up once and down once makes that "repeating railroad click-a-clack" sound go away.

    My best theory is that the phone supports various plugs (3 & 4 segment), and by sending input it realizes which type of headphones you have in the adapter. Perhaps the clicks are the result of it trying to sense or use a non-headset headphone congiruation with an earbud headset.

    Prior to this, I'd tried everything from cleaning the contacts with alchol to trying every combination of polarity with my lightening adapters. Nothing worked. However a simple volume up (++) and down (--) on the controls of my headset cord works every time.
    --- Post Merged, Nov 16, 2017 ---
     

Share This Page