Headphone background noise? MBP 13" Mid 2013

Cryosim

macrumors newbie
Original poster
Dec 15, 2014
25
0
Hey there,
When I popped over to Singapore on my way back to Australia I bought myself a new pair of Valore HS0003 gaming headphones. However, once I plugged them into my MacBook via USB... I started hearing this almost earsplitting background pinging noise whenever a sound was played. E.G I would turn the volume up, the "volume turned up" sound would play, and the sound would come at me full force and then persist for a few seconds even AFTER the sound had finished playing. The volume did not vary even when I turned the volume to full in my Mac's settings, this leads me to believe it's a hardware issue although it works fine on my windows PC (see below), so it could be a driver issue? It's hard to describe what it sounds like; just imaging a sort of pinging, constant electronic beep. Keep in mind this was 1-2 hours after I bought it and I had just taken it out of its packaging. I use a three-prong grounded connector for my Mac, disconnecting the Lightning connector while playing sound did nothing to change it. I plugged it into a spare Windows laptop, and to my surprise the sound was still there, but barely audible. Any fixes for this?

Thanks,
CitadelCore/Cryosim
 

Samuelsan2001

macrumors 604
Oct 24, 2013
7,682
2,103
Have you tried other earphones or headphones?? If so and they are fine I don't know what you want us to say if they aren't compatable then all you can do is contact Valore.
 

Cryosim

macrumors newbie
Original poster
Dec 15, 2014
25
0
I've tried them and they work perfectly... Valore has no contact page or phone number...
 

Cryosim

macrumors newbie
Original poster
Dec 15, 2014
25
0
Yeah... I'm in Australia now. Valore dosen't operate in Australia. And I'm pretty sure the headphones aren't defective, I'm missing a driver or have incorrect settings on my Mac or something. Because as I said it works fine using my Windows laptop.