Headphone jack doesn't 'snap' anymore.

Discussion in 'iPhone' started by Kauai, Jun 21, 2011.

  1. Kauai macrumors 6502a

    Joined:
    Oct 13, 2010
    #1
    I'm not really sure how to describe this, but the headphone jack on my iPhone 4 doesn't 'snap' anymore - this started yesterday when I was trying to plug in my headphones but it kept playing through the speakers. Now it will 'slip in' silently and the hold seems to be OKAY - hasn't fallen out or anything, but with my warranty expiring soon I don't want this issue to degenerate to the point of the headphone jack not working.

    Should I get this checked out? Anyone have any experience with this?
     
  2. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #2
    A friend of mine had this issue. They fixed it by sticking a pin into the headphone jack and poking around and they got out a huge lump of dirt and dust that fixed it.
     
  3. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #3
    Probably just dirty. Don't use any liquids though, but just shine a flashlight into the hole and see if you can spot any dirt then use a pin or something to try and get it out.

    If nothing, then just bring it in to an Apple Store and explain your situation.
     

Share This Page