Headphone Jack Messed Up !

Discussion in 'MacBook Air' started by badman89, Mar 14, 2012.

  1. badman89 macrumors regular

    Dec 24, 2011
    Hey, I seem to have messed up the headphone jack in my MBA although I have absolutely no idea how I messed it up or what I did. I do not think I have subjected any part of my MBA to anything but safe treatment.

    Symptoms: I can only hear audio from one earphone (the right side) while the left earphone is completely dead. Tweaking the balance settings in System Preferences has revealed this to be (in my uninformed opinion) a hardware problem:
    1. If the balance bar is in the middle, I hear audio through the right earphone only.
    2. If the balance bar is to the extreme right, I hear audio through the right earphone only.
    3. If the balance bar is to the extreme left, I hear absolutely nothing.

    Anybody have any idea what I could do (other than take it to the apple store obviously).

    Thanks very much.

    PS: Before you ask me, no, the problem is not with the headphones :p because I have tested numerous headphones. All the headphones I tested show this problem with my MBA but are perfectly normal with other devices.
  2. martinm0, Mar 14, 2012
    Last edited: Mar 14, 2012

    martinm0 macrumors 6502a

    Feb 27, 2010
    Only time I've had this problem is when I've failed to push the headphone plug all the way in. It leaves that last band on the plug from being fully seated.

    If you haven't tried this, just ensure you have these pushed in all the way. Try another pair if you have them to verify if the issue is happening with both sets, or just one. It could be that you tweaked the plug when it was in the port and it pushed the bands out of the way inside the port. You could also plug them into a separate jack and pull them out slightly and see if you can reproduce the issue on another device. Good luck!

    Edit - ignore the suggestion on trying other headphones.
  3. wayne905 macrumors member


    Mar 9, 2012
    Maple, Ontario, Canada
    If you've checked the plug is inserted all the way into the jack, try spinning the plug while it's plugged in. At times I have the same issue as you, and by spinning the jack around, it fixes it (I tend to find a sweet spot that makes it work and then I don't move it again).
  4. badman89 thread starter macrumors regular

    Dec 24, 2011
    Sorry, perhaps I should also have included these things in my original post but I have already tried all these things. No luck :(

    Also, it was perfectly fine up until a couple of days ago.
  5. martinm0 macrumors 6502a

    Feb 27, 2010
    I'm stumped. I would think that maybe you had the headphones plugged in and it slid to the side and tweaked the inner port. Otherwise, seems like sort of a fluke. Is it out of warranty? I don't think that port is separate from the others, meaning that replacing it most likely requires a new logic board (or jack pack). Sorry!

Share This Page