Headphone jack not working

Discussion in 'iMac' started by coolurjets, Mar 3, 2008.

  1. coolurjets macrumors newbie

    Joined:
    Mar 20, 2007
    Location:
    UK
    #1
    My headphone jack for my iMac Intel (white) has stop working. When ever I try to connect a pair of headphones or external speakers, the iMacs internal speakers stop playing but no sound comes out of the headphones or externals.

    Anyone know why this is or prehaps an option to turn it back on?

    Any help would be great, thanks. :)
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Sounds like they may be dammaged, or you need to adjust the sound preference pane. If it can't work, I'd see if Apple Care would cover it, or maybe an Apple Authorized Repair Center.

    TEG
     
  3. Javanation macrumors newbie

    Joined:
    Feb 8, 2008
    #3
    Same thing happened to me- Apple Tech's Solution

    My speakers stopped working after 6 months. The internal speakers came on after I unplugged, but after plugging back into the jack, nothing. I tried zapping PRAM, making sure that my sound devices were not set to mute, etc. as others suggested on other forums but no go. I called Apple Tech support. She had me shut down and then unplug everything from the Imac. I then plugged back in the power cord and pushed and held in the power button until the Imac started. I plugged back in my keyboard and mouse, logged in, and plugged back in my speakers and Voila: SOUND from my speakers. She told me that what I did was reset my ports. She didn't know why the headphone jack when on the fritz in the first place.

    (I also posted on Apple support forum)
     
  4. jamisonbaines macrumors regular

    Joined:
    Dec 14, 2007
    Location:
    CA
    #4
    having the same issue on my mini

    my hope is that the optical will work because the headphone port is done. it would static out and you'd have to jiggle the headphones around for a few months prior to that fwiw
     
  5. superflex macrumors newbie

    superflex

    Joined:
    Jul 1, 2009
    #5
    Headphone jack not working

    If you've tried resetting ports which means you would shut down, disconnect everything at the back, push and hold the power button until you see a couple flashes at the on light indicator and release when you hear the chime. Reconnect mouse keyboard etc and log in. If it's still not working you've got a dead audio board or at the least an audio board that may have come loose at the ribbon cable connector off the interconnect board.

    Simple fix really, all you would need is one of these @ $60.00 bucks.. http://www.mac-pro.com/s.nl;jsessio...363.e3eSc3uNaNuTe34Pa38Ta38Qc3r0?it=A&id=4307

    And then follow these instructions... Installing Mac mini Audio Board http://www.ifixit.com/Guide/Repair/Mac-mini-Model-A1283-Audio-Board/1059/1

    Of course this is taking into account yer not simply in mute (wink)
     
  6. jamisonbaines macrumors regular

    Joined:
    Dec 14, 2007
    Location:
    CA
    #6
    nice update.
    pleasant surprise to see the thread update in my mailbox. I need to put in a larger HD anyways so it's definitely worth a shot to fix it.

    i have audio going through a fw interface as it stands right now which works ok but it would be nice to get it fixed.
    thanks for posting superflex.
     

Share This Page