Headphone port broke

casperes1996

macrumors 601
Original poster
Jan 26, 2014
4,666
2,450
Horsens, Denmark
Hey, guys!

Today, I was playing my guitar with my iMac using amps in GarageBand. I was using a TRRS splitter with the headphone port to get an input for the guitar and an output for my speakers. All was working well, until all I got was feedback and nothing else. I checked all the cables, and it appears the port on my iMac broke somehow. It can receive no signal, and there's no resistance when you try and push in cables like there usually is. They just sweep in and out with no push-back from the computer.

Anything I can do, or is it a goner? Think Apple will replace it for free/think they'll charge a lot to fix it? PS. no actual Apple Stores in my country, only Premium Resellers. (Humac)

Thanks.

Oh, and by the way - if I can't get it fixed, any suggested USB solutions?
 

casperes1996

macrumors 601
Original poster
Jan 26, 2014
4,666
2,450
Horsens, Denmark
Just want to add that if anybody wants to suggest a USB DAC, I'd prefer one with similar or better specs to the internal one, preferably cheap, small, with low lag and an amp isn't necessary as all I might connect to it is active (speakers mostly). One that supports both input and output would be nice. (i.e. guitar + speakers or mic + speakers. Again, not required, just preferred. If it's much cheaper without, I'm fine with just speakers, using another device for inputs)
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.