headphones won't fit all the way into jack

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sleepykidd, Feb 10, 2012.

  1. sleepykidd macrumors newbie

    Nov 18, 2010
    Hi, for some reason this morning none of my headphones will fit into the headphone jack of my 4S. I tried two earbuds and a SONY headset but none of them worked. The headphones DO work on my computer with no issue. They fit in, but only up to the point where the last metal segment of the headphone is still sticking out of the jack. I have tried to push them in but for some reason it won't budge.

    I'm really confused as to what is going on, I haven't had any kinds of problems like this in the 2 months I've had the phone.

    I called Apple and apparently the only thing they are willing to do is replace the phone. I'd rather not have to go through reloading all of my stuff into a new phone and it works fine, the only problem is with the headphone jack.

    Anyone know what the problem is or any way that I can mend it without having to resort to a replacement. I do have warranty but the nearest Apple store to me is like a 3 hour drive.

    As a last resort I'm thinking about just getting a set of blue tooth headphones, that would work right?
  2. normanbates macrumors regular

    Aug 24, 2011
    Have you checked to see if there is anything stuck in the jack?
  3. sleepykidd thread starter macrumors newbie

    Nov 18, 2010

    There doesn't appear to be anything, (at first I thought it might be lint but I scraped around with a paper clip = nothing.)
  4. normanbates macrumors regular

    Aug 24, 2011
    Check that the headphones fit into another device. If they do try another pair of headphones in the iPhone.

    You do need to give them a bit of pressure to get them in sometimes
  5. TheCommonCup macrumors newbie

    Jun 25, 2012
    Having the same problem

    I'm having the same problem...
    It randomly began happening.
    Not sure what's wrong.
    First I thought it was my BEATS.
    Then I tried my Apple headphones.
    Nothing works.

Share This Page