Heads up for NVMe/SATA FUSION drives in Mojave.

Discussion in 'macOS Mojave (10.14)' started by SneakyTLoD, Sep 18, 2018.

  1. SneakyTLoD macrumors member

    Joined:
    Apr 6, 2018
    #1
    Mojave installation will change the fusion drive to APFS without option. Mine completely stopped working once that happened. I have an 850 evo on an OWC card and a SM951 combined into a fusion drive. I had to install Mojave on a different hard drive and CCC it over to the fusion drive. Works great when using Mac OS extended journaled on the fusion drive. Getting about 1500mbs up and down with the combined drive just like with HS. It confused me for a couple of days as Mojave worked fine on my backup HDD but then acted like the video card was the issue when installed on said fusion drive. Nope the APFS format of the drive was the issue. Just FYI for those of you using the fusion option.
     
  2. crjackson2134 macrumors 68040

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #2
    Thanks SneakyTLoD, but this post would really be more helpful if placed in the Mojave section. Probably there are fewer MP users using Fusion than any other systems.
     
  3. SneakyTLoD thread starter macrumors member

    Joined:
    Apr 6, 2018
    #3
    I posted it here as it has more to do with unsupported aftermarket NVMe boot options which only Mac Pro user will be trying. I know a lot of people have opted for efi hacks for NVMe boots but there are some of us that chose the fusion route prior to that being an option and are happy with it.
     
  4. doonie macrumors newbie

    Joined:
    Sep 19, 2018
    #4
    Could you show your diskutil apfs list? I couldn't get Mojave to boot after install on a clean new apfs container with ssd-sata + nvme. So just adding a Mac osx extended partition would help the boot to see the drives?
     
  5. SneakyTLoD thread starter macrumors member

    Joined:
    Apr 6, 2018
    #5
    I created the fusion drive with Mac OS Extended (Journaled) then used Carbon Clone Copy to clone the Harddrive that Mojave was successfully installed on. This allows you to keep the Mac OS Extended (Journaled) format on the fusion drive so that it is still bootable.
     
  6. Sevenfeet macrumors member

    Joined:
    Dec 9, 2008
    #6
    I'm beginning to prepare for my Mac 3,1 and Fusion drive upgrade but I'm not using a PCI card to make the SSD side of the equation happen. I would think that if both were on the main SATA bus, this might not be a problem. Still, I need to work this into the list of things that might go wrong. SoftRAID has just released a Mojave compatible version (5.7) so I'm good to go there.

    Of course, backup twice before doing anything!
     
  7. SneakyTLoD thread starter macrumors member

    Joined:
    Apr 6, 2018
    #7
    The main reason my drive was created as a fusion drive was to allow the boot-ability of the sata ssd while retaining most of the speed of the NVMe. It's a rare use case for sure, though I know of a few others using it. I also tried software raid 0 but the performance dropped to the speed of the sata drive.

    I would suspect that a traditional fusion drive would not have this problem and apfs would work as expected but I can't be for sure. Though I still feel like this belongs in the Mac Pro section as I doubt it affects anyone else.
     
  8. SneakyTLoD thread starter macrumors member

    Joined:
    Apr 6, 2018
    #8
    Update. I was able to get the fusion drive formatted to APFS and still be bootable. For some reason you have to disable SIP. Have no idea why but that did the trick. Maybe something to do with it showing as an external drive? If I re-enable it goes back to being non-bootable. Go figure.
     
  9. SneakyTLoD thread starter macrumors member

    Joined:
    Apr 6, 2018
    #9
    May have spoken too soon. Though I am bootable once again it seems as though my speeds are restricted to SATA3. Guess it's time to split it up and go with nVME boot on the Mac Pro. Time to hack my ROM!
     
  10. doonie macrumors newbie

    Joined:
    Sep 19, 2018
    #10
    I also read about the disable SIP tip, didn't try it. Let us know how the ROM hacking / driver injection goes :)
     
  11. Earl Urley macrumors 6502

    Joined:
    Nov 10, 2014
    #11
    No, just wait for the release of 10.14.1, it has a firmware updater that includes BootROM 140.0.0.0 which has the NVMe driver already injected.. by Apple!
     
  12. MIKX macrumors 6502a

    MIKX

    Joined:
    Dec 16, 2004
    Location:
    Japan
    #12
    tsialex says that there are problems with the Samsung 850 EVO.
     
  13. DaSal, Feb 9, 2019
    Last edited: Feb 9, 2019

    DaSal macrumors regular

    Joined:
    Mar 19, 2008
    Location:
    The Netherlands
    #13
    I'm trying the same thing and am having the same issue. I now have an APFS fusion drive with a 1TB SSD + the built in NVME. It's working normally (stable), however, I'm not the SSD speeds, not the NVME speeds.

    EDIT: figured out a fix for this. The problem is that the fusion drive has the wrong drive selected as the main drive. Fix here: https://forums.macrumors.com/thread...-isnt-reaching-nvme-blade-ssd-speeds.2169105/
     

Share This Page