Headset Button Not Working

Discussion in 'iPhone Accessories' started by chcameron, Jan 5, 2009.

  1. chcameron macrumors newbie

    Joined:
    Jan 2, 2009
    #1
    The headset button (play/next track/call answer etc) has stopped working. I tried it with two different headsets (the apple one and a new one I bought at the apple store, the v-moda vibe ii), and they both dont work, so I think its a problem with the phone. Tried rebooting the phone, still doesn't work.

    Anybody have this problem?
     
  2. iphonuser macrumors newbie

    Joined:
    Jan 13, 2009
    #2
    Same problem to me today, I've turn off/on the iphone and tried with another iPhone headset and buttons on both headset doesn't work...I also cleaned the female jack...
    I will try to do and hard reset?

    Another topic here of the same problem here
     
  3. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #3
    I had the same problem, I got a replacement headset at an O2 store, but it didn't work either (they tested it on a display iPhone and it worked fine).

    I was planning to go to my nearest Apple store (miles away), but thought I'd trying cleaning out the jack. I rolled up a cinema ticket, stuck it in and twisted it a few times (there's probably a better way to clean it!) and now the headphones, mic and button all work fine!
     
  4. hover macrumors newbie

    Joined:
    Jul 23, 2007
    #4
    I had the same problem with my iphone 3G recently: headset mic and button stopped working. Noticed that the headset jack actually did not go in fully - a small gap remained. Figured out it must had been some fluff accumulated from carrying the iphone in the pocket.

    It took two attempts and was quite difficult to extract the fluff with a sewing needle. So take care - it can easily happen to anyone.
     
  5. andyhargreaves macrumors regular

    Joined:
    Dec 23, 2007
    #5
    Yes

    Just to confirm, this worked for me too!

    Andy
     
  6. applemut macrumors newbie

    Joined:
    Oct 18, 2008
    #6
    Had same problem. Button and microphone not working (headset speakers were working). Follwed the above suggestion but used a paper clip. I could not see much fuz in there, but I was amazed at how much ended up coming out. Everything worked great afterwards!
     
  7. michaelberliner macrumors newbie

    Joined:
    Nov 24, 2010
    #7
    Wow!

    Guys - thank you so much. I've been putting up with not having a working handsfree/headset buttons for the best part of a year - two different headsets hadn't worked with my 3GS so I'd assumed the function had just broken in my phone. Saw this thread, tried clearing out my phone's earphone socket with a paper clip, and IT STARTED WORKING!

    Got to love a free fix. THANK YOU!!!
     

Share This Page