Healthkit not working/showing anything

Discussion in 'iOS 9' started by borgqueenx, Nov 4, 2015.

  1. borgqueenx macrumors 65816

    Joined:
    Jul 16, 2010
    #1
    The app FitPort and healthkit are not showing any data whatsoever. 0 steps, 0 stairs, 0 distance, nothing.

    Then i downloaded Steps+ and i could see my steps. Steps i made today, yesterday, the whole week....

    Why is it not writing to healthkit? Why is FitPort not showing anything?

    Any ideas?
     
  2. thed0g macrumors regular

    Joined:
    Oct 22, 2015
    #2
    Did you downgrade from 9.1 to 9.0.2 perhaps ?
     
  3. borgqueenx thread starter macrumors 65816

    Joined:
    Jul 16, 2010
    #3
    Yes, but i restored not "updated" to 9.0.2.
     
  4. thed0g macrumors regular

    Joined:
    Oct 22, 2015
    #4
    So, you used shift click to install 9.0.2 , then restored a previous 9.0.2 backup ?

    I asked because when downgrading from 9.1 to 9.0.2 with shift click you preserve everything, but the health data can't be read or written again. You can fix it only by making an unencrypted itunes backup (which doesn't preserve Health data), then restoring the phone from that backup. This resets Health and is fully functional again.
     
  5. !!! macrumors 6502

    Joined:
    Aug 5, 2013
    #5
    HealthKit is an API developers use to connect to your Heath data. It's not an app. Health is an app Apple makes for iPhone for users to track their health data.
     
  6. acctman macrumors 65816

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #6
    :rolleyes:
    were you able to get the app to work again? I can't go it to pick up my Apple Watch as a source either.
     
  7. throwthedice macrumors regular

    Joined:
    Aug 27, 2015
    #7
    Are there any known issues with the Health App on iOS 9.1? Nothing seems to be recorded on them :(
     
  8. acctman macrumors 65816

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #8
    try doing an iTunes backup then Reset Erase All Content and Settings ... then restore the backup from iTunes. After trying everything this ended up working for me.
     

Share This Page