Heart rate metric no longer available on Workout app

Discussion in 'Apple Watch' started by venger, Jan 16, 2017.

  1. venger macrumors newbie

    Joined:
    Feb 15, 2011
    #1
    Hi all,
    Have been a forum lurker for years, and TBH have usually found a solution through the Search option for my troubles.

    Unfortunately, have come across this issue yesterday on my 2-week old Apple Watch series 2...

    I have been using Workout for my outdoor runs without issues for these past 2 weeks - showing 5 metrics: Time lapsed, Current pace, Distance, Heart rate and Average pace.

    However, yesterday I was tweaking my settings (as I do) & thought I'd tried turning off Background App Refresh. I did this just before my run.

    - And when I was in the middle of my run, I noticed that my Heart Rate was no longer showing as a metric.
    - At the end of my run, the session saved without any Heart Rate measured.
    - When I go into My Watch\Workout\Outdoor Run, the Heart Rate metric is greyed out.
    - In my phone's Health app, I can still see the regular Heart Rate being monitored. But just not working when I start a Workout session.

    I tried a few things to fix:
    - turning on/off watch
    - re-enabling Background App Refresh for Health, Activity, Heart rate, Workout, turning on/off watch
    - un-pairing & re-pairing watch
    - have installed Heartwatch to check that my heart rate can be monitored - the sensor is still working.

    Has anyone else come across this issue & know of a solution?

    Help....
     
  2. klymr macrumors 65816

    Joined:
    May 16, 2007
    Location:
    Utah
    #2
    I haven't played around too much with the workout app, or metrics for that matter, but I did just find this via a quick google search. Might be helpful. http://www.imore.com/how-view-goal-metrics-workout-apple-watch#add
     
  3. venger thread starter macrumors newbie

    Joined:
    Feb 15, 2011
    #3
    Thanks for responding. Unfortunately, No, that article doesn't provide a solution.

    My problem is that the Heart Rate metric is "greyed out" - that is I can still add/re-order the metric in settings, but the Workout app is not able to measure / display it for some unknown reason.

    I am guessing my disabling of Background App Refresh has broken something in Workout/Heart Rate - but don't know how to fix it. Re-enabling the background refresh doesnt' seem to help.
     
  4. klymr macrumors 65816

    Joined:
    May 16, 2007
    Location:
    Utah
    #4
    Ah, gotcha. I've seen mine do that once or twice while running a workout, and just adjusting the watch on my wrist has fixed the issue. Sounds like yours is having other problems though. How about your privacy settings? Under the Motion and Fitness section, is Heart Rate turned on?
     
  5. venger thread starter macrumors newbie

    Joined:
    Feb 15, 2011
    #5
    Yes - all turned on in My Watch\Privacy - both Heart monitoring and Fitness tracking are ON.
     
  6. klymr macrumors 65816

    Joined:
    May 16, 2007
    Location:
    Utah
    #6
    Sorry I'm not much help. Only other thing I can think of (with my limited knowledge of the Apple Watch): have you checked the Workout Power Saving Mode under General settings?
     
  7. venger thread starter macrumors newbie

    Joined:
    Feb 15, 2011
    #7
    No need to apologise - glad you are offering advice. It's good to run through the steps anyhow.
    These steps will help others in future, no doubt.
    In my case though, the Workout Power Saving mode is OFF. So don't think this is the reason.

    I am going to pay my local Genius a visit later. Perhaps a final unpair-re-pair & turn off/on before my visit.

    thanks again...
     
  8. Newtons Apple, Jan 17, 2017
    Last edited: Jan 17, 2017

    Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #8
    MY HR used to grey out all the time or after running for 30 minutes it would show 60bpm. Sorry but I have little faith in the AW's ability to maintain a HR reading as I had trouble on all three of my watches.
     
  9. CaptMarvel macrumors 65816

    CaptMarvel

    Joined:
    Sep 20, 2014
    Location:
    North Carolina
    #9
    Maybe try unpairing and re-pairing the Apple Watch? Then set up as new if nothing seems to work. All of your workout data won't be lost as it's saved on your iPhone.
     
  10. aaplwatch macrumors member

    Joined:
    Jun 14, 2016
    #10
    This is definitely a problem in OS 3.1

    Getting a reading during high intensity outdoor runs has become a crapshoot. It sometimes takes up to 6 minutes. Has rendered HR metrics useless.

    If I'm standing still and/or not working very hard it comes up rather quickly. Same for cycling workouts.

    Has to do with arm movement and intensity is my guess. This is a new issue. Wasn't a problem previously.

    Really hope they fix this!
     
  11. FrankJulich macrumors newbie

    FrankJulich

    Joined:
    Feb 24, 2017
    #11
    I had the same problem after updating to Watch OS3.1.3. The heart rate metric was greyed out for walks and runs, but fine with all other workout types.

    The solution was to unpaid the device and pair "as new".

    No data was lost, but I had to set up my app layout and notification alerts again. Totally worth the extra bit of effort.
     
  12. Bbauerm macrumors newbie

    Joined:
    Apr 9, 2017
    Location:
    Port Townsend
    #12
    Thanks for this tip Frank. I was hoping it would not come to this - just because unpairing and repairing takes a while. Also, even if you restore from a back up your Apple Pay data is lost (thank god) and needs to be reentered. Unfortunately for me, this did not do the trick. My Heart Rate option is still greyed out for both Outdoor Run and Outdoor Walk and nothing else. Earlier today I also updated to the 3.1.3 version of the Watch OS. My watch is a Series 2. Still looking for a solution.

    For those who wish to help, like Frank my situation is: heart rate in other apps works fine - even in the Workout App (from Apple) it works for everything except running and walking. That's the odd part. Is it a conflict from some other running app?
    --- Post Merged, Apr 9, 2017 ---
    I FOUND IT! The clue was in Frank's message. On your iPhone, go to the Watch app, select My Watch, General, and turn off the Workout Power Saving Mode near the bottom. It's a feature, not a bug! Who'd a thunk it.
     

Share This Page