Heatsink/Fan?

Discussion in 'PowerPC Macs' started by eyoungren, Jan 30, 2014.

  1. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #1
    Recently acquired a Powerlogix dual 1.6Ghz processsor card for my Quicksilver Mac. Came out of a PowerMac G4 AGP. The card fits fine, but the heatsink and fan do not. The heatsink goes right through where the ram slots and the AGP slot is for my QS.

    It's impossible to relocate the heatsink because the design makes it one way only. I can't use the fan/heatsink from my Sonnet upgrade because the fan connector is not molex and relies on power from the board. The fan from the new processor card is too large to fit the heatsink from the Sonnet upgrade.

    So, my question is…would anyone have a heatsink for this new dual processor card? Specifically one that's supposed to work with this card?

    Alternatively I was thinking of trying to find a heatsink/fan from one of the dual processor Quicksilvers, but I don't know if that would work or not.

    Note that I am missing the original heatsink and fan (and 733mhz processor card) from this Quicksilver. It was not included with the sale (I'm the third owner and the second owner didn't get it either) as the Sonnet upgrade was installed when I got it.

    Thanks for any suggestions!
     
  2. DZ/015 macrumors 6502a

    DZ/015

    Joined:
    Mar 23, 2003
    Location:
    New England
    #2
    I don't know about Powerlogix, but the Sonnet and GigaDesigns processors I've had used an adhesive thermal pad instead of heat sink compound. Not easy to separate.

    Anyway, I have a request/offer to make.

    I recently came into possession of a GigaDesigns dual 1.8 G4. Guy was using it in a quicksilver (at 1.6GHz). Claimed it worked well. I dragged out my AGP and got to work. Everything went well, but Tiger was not stable. Had spinning beach balls and finder lockups. OS 9, however, ran like a champ. No problems after running for hours. Tiger would run for 15 minutes, tops. Tried reinstalling the system software, removing added hardware, adjusting core voltage, adjusting processor speed, etc. but could not get it to run OS X. I have lost patience with it.

    I could send it to you for testing in your quicksilver. Maybe it will work, maybe it won't. If it works, great. Perhaps a simple straight up trade for your dual 1.6 could be made. If it does not work, you could send it back. Or make a cool video of its destruction.

    Whaddaya say?
     
  3. eyoungren thread starter macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    Sounds good to me. PM me!
     
  4. Hughmac macrumors demi-god

    Hughmac

    Joined:
    Feb 4, 2012
    Location:
    Kent, UK
    #4
    The DIY way would be to get a large fan with HDD power connector and position it in the right place with cable ties.

    Cheers :)

    Hugh
     
  5. eyoungren thread starter macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #5
    Allright…here is the rest of the story!

    Got the processors today (thanks DZ/015). Now, I do not have the original screws for the original CPU card, nor do I have the original CPU card.

    I had found three screws that fit previously for the other dual CPU I got. So I held on to them. But I had to cut them down to fit. Did that, lost one screw in the process, but with this particular Giga Designs cpu it's hard to get to the third screw hole (heatsink is in the way) so I just used the first two.

    But first I updated the Mac per the instructions. Run the updater, wait until the Mac shuts down, press the programmer button and hold until I get a long tone. Purple screen after boot telling me the update was successful and that the Mac would shut down. So, on to installing the processors

    The directions for this card state to replace the original fan that was behind the original heatsink. Guess what? I don't have that fan either. So I ordered one from eBay. Both the processor and the fan came today. And of course, since I didn't have the fan I also did not have the two screws that worked with it.

    Half my time was spent finding screws! But, two old case screws from my old TiBook/400 fit. So, in went the fan. I set the CPU for 2.0Ghz.

    Chime! But black screen. Fine, I'll downstep to 1.8Ghz. Hurray! boot. But, I boot to a blue screen. A bit of troubleshooting and then I remember some research I did before starting. So, I did a bit more and it turns out I'm missing one element. This CPU needs to install a kernel extension to run properly. OK. Well, TDM will solve that. Not.

    Problem 1. My boot drive is SATA. My PowerBook doesn't see it. All it sees is the first 128GB of my RAID drive!
    Problem 2. After pulling the SATA drive and putting it in a case, my PowerBook will not see the drive as a boot drive. Nor will the updater install to any drive OTHER than the boot drive! So, off to OpenFirmware to boot from USB. That works! Install the updater, shut down (after updating boot caches), take the SATA drive out of the case and put it back in the QS and boot!

    Got all the way logged in and the Mac freezes. So, troublehoot for an hour or so, it only stays up for a small amount of time. Finally, I reread this thread and decide that since the first owner was running this card in his QS at 1.6Ghz, that's what I'll try too.

    And now we're stable! I am typing this on a Dual 1.6Ghz PowerMac G4 Quicksilver!
     

    Attached Files:

Share This Page